Skip to content
Laskyr

Plugins · notification-for-telegram · data as of 2026-11-04

Is Notification for Telegram safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.5)

As of 2026-11-04. 6 issues are on record for older versions; version 3.5.3 or newer fixes all of them that state a fix.

Latest version
3.5.5
Last updated
2026-09-18
Active installs
4,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Sends notifications to Telegram users or groups, when some events occur in WordPress. — by rainafarai

What to do

  1. Update to the latest version (3.5.5). Anything older than 3.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get notification-for-telegram --field=version shows what you run; wp plugin update notification-for-telegram updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-93514 · published 2026-09-30

Cross-site scripting (XSS) in Notification for Telegram (3.5.2 and older)

Affected
3.5.2 and older
Fixed in
3.5.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Notification for Telegram <= 3.5.2 versions.

NVD CVE-2026-93514Patchstack advisory

medium 4.3 CVE-2026-7620 · published 2026-07-11

Missing authorization check in Notification for Telegram (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Notification for Telegram plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.5.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to create, modify, or reschedule the nftb_cron_hook WordPress cron event, enabling unauthorized manipulation of the plugin's background task scheduling logic.

NVD CVE-2026-7620Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-40732 · published 2026-06-15

Cross-site scripting (XSS) in Notification for Telegram (3.5 and older)

Affected
3.5 and older
Fixed in
3.5.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Notification for Telegram <= 3.5 versions.

NVD CVE-2026-40732Patchstack advisory

medium 4.3 CVE-2025-62993 · published 2025-12-09

Missing authorization check in Notification for Telegram (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in rainafarai Notification for Telegram notification-for-telegram allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Notification for Telegram: from n/a through <= 3.5.1.

NVD CVE-2025-62993Patchstack advisory

medium 4.3 CVE-2025-58794 · published 2025-09-05

Cross-site request forgery (CSRF) in Notification for Telegram (3.5 and older)

Affected
3.5 and older
Fixed in
3.5.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in rainafarai Notification for Telegram notification-for-telegram allows Cross Site Request Forgery.This issue affects Notification for Telegram: from n/a through <= 3.5.

NVD CVE-2025-58794Patchstack advisory

medium 4.3 CVE-2024-9685 · published 2024-10-10

Missing authorization check in Notification for Telegram (3.3.1 and older)

Affected
3.3.1 and older
Fixed in
3.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Notification for Telegram plugin for WordPress is vulnerable to unauthorized test message sending due to a missing capability check on the 'nftb_test_action' function in versions up to, and including, 3.3.1. This makes it possible for authenticated attackers, with subscriber-level access and above, to send a test message via the Telegram Bot API to all users configured in the settings.

NVD CVE-2024-9685Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Notification for Telegram vulnerability status badge
<a href="https://laskyr.com/plugins/notification-for-telegram"><img src="https://laskyr.com/plugins/notification-for-telegram/badge.svg" alt="Notification for Telegram vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit