Skip to content
Laskyr

Plugins · ninja-gdpr-compliance · data as of 2026-11-04

Is GDPR CCPA Compliance & Cookie Consent Banner safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.5)

As of 2026-11-04. 5 issues are on record for older versions; version 2.7.5 or newer fixes all of them that state a fix.

Latest version
2.7.5
Last updated
2026-08-23
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Get compliance with GDPR, CCPA, DPA, and other privacy regulations. — by Ninja Team

What to do

  1. Update to the latest version (2.7.5). Anything older than 2.7.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ninja-gdpr-compliance --field=version shows what you run; wp plugin update ninja-gdpr-compliance updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-68073 · published 2026-01-22

Missing authorization check in GDPR CCPA Compliance & Cookie Consent Banner (2.7.4 and older)

Affected
2.7.4 and older
Fixed in
2.7.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ninja Team GDPR CCPA Compliance Support ninja-gdpr-compliance allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GDPR CCPA Compliance Support: from n/a through <= 2.7.4.

NVD CVE-2025-68073Patchstack advisory

medium 4.3 CVE-2025-48260 · published 2025-05-19

Missing authorization check in GDPR CCPA Compliance & Cookie Consent Banner (2.7.3 and older)

Affected
2.7.3 and older
Fixed in
2.7.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ninja Team GDPR CCPA Compliance Support ninja-gdpr-compliance allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GDPR CCPA Compliance Support: from n/a through <= 2.7.3.

NVD CVE-2025-48260Patchstack advisory

high 8.8 CVE-2025-24591 · published 2025-01-24

Missing authorization check in GDPR CCPA Compliance & Cookie Consent Banner (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
2.7.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Ninja Team GDPR CCPA Compliance Support ninja-gdpr-compliance allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects GDPR CCPA Compliance Support: from n/a through <= 2.7.1.

NVD CVE-2025-24591Patchstack advisory

medium 5.4 CVE-2024-5607 · published 2024-06-07

Missing authorization check in GDPR CCPA Compliance & Cookie Consent Banner (2.7.0 and older)

Affected
2.7.0 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The GDPR CCPA Compliance & Cookie Consent Banner plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions named ajaxUpdateSettings() in all versions up to, and including, 2.7.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the plugin's settings, update page content, send arbitrary emails and inject malicious web scripts.

NVD CVE-2024-5607Wordfence advisoryCode change (fix)

critical 9.8 CVE-2020-36718 · published 2023-06-07

PHP object injection in GDPR CCPA Compliance & Cookie Consent Banner (2.3 and older)

Affected
2.3 and older
Fixed in
2.6.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The GDPR CCPA Compliance Support plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.3 via deserialization of untrusted input "njt_gdpr_allow_permissions" value. This allows unauthenticated attackers to inject a PHP Object.

NVD CVE-2020-36718Wordfence advisoryWPScan advisoryCode change (fix)wordpress.orgblog.nintechnet.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
GDPR CCPA Compliance & Cookie Consent Banner vulnerability status badge
<a href="https://laskyr.com/plugins/ninja-gdpr-compliance"><img src="https://laskyr.com/plugins/ninja-gdpr-compliance/badge.svg" alt="GDPR CCPA Compliance & Cookie Consent Banner vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit