Skip to content
Laskyr

Plugins · ngg-smart-image-search · data as of 2026-11-04

Is NGG Smart Image Search safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.0)

As of 2026-11-04. 5 issues are on record for older versions; version 4.0.0 or newer fixes all of them that state a fix.

Latest version
4.1.0
Last updated
2026-10-27
Active installs
400+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

NGG Smart Image Search provides smart search and display functionalities for images in NextGEN galleries. It requires NextGEN Gallery to be installed … — by wpo-HR

What to do

  1. Update to the latest version (4.1.0). Anything older than 4.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ngg-smart-image-search --field=version shows what you run; wp plugin update ngg-smart-image-search updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-73185 · published 2026-08-19

SQL injection in NGG Smart Image Search (older than 4.0.0)

Affected
older than 4.0.0
Fixed in
4.0.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in NGG Smart Image Search < 4.0.0 versions.

NVD CVE-2026-73185Patchstack advisory

medium 6.5 CVE-2025-58027 · published 2025-09-22

Stored cross-site scripting (XSS) in NGG Smart Image Search (3.4.3 and older)

Affected
3.4.3 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpo-HR NGG Smart Image Search ngg-smart-image-search allows Stored XSS.This issue affects NGG Smart Image Search: from n/a through <= 3.4.3.

NVD CVE-2025-58027Patchstack advisory

critical 9.3 CVE-2025-52832 · published 2025-07-04

SQL injection in NGG Smart Image Search (3.4.1 and older)

Affected
3.4.1 and older
Fixed in
3.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in wpo-HR NGG Smart Image Search ngg-smart-image-search allows SQL Injection.This issue affects NGG Smart Image Search: from n/a through <= 3.4.1.

NVD CVE-2025-52832Patchstack advisory

medium 6.5 CVE-2025-47503 · published 2025-05-07

Stored cross-site scripting (XSS) in NGG Smart Image Search (3.3.3 and older)

Affected
3.3.3 and older
Fixed in
3.4.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpo-HR NGG Smart Image Search ngg-smart-image-search allows Stored XSS.This issue affects NGG Smart Image Search: from n/a through <= 3.3.3.

NVD CVE-2025-47503Patchstack advisory

medium 5.4 CVE-2024-13658 · published 2025-02-12

Stored cross-site scripting (XSS) in NGG Smart Image Search (3.2.1 and older)

Affected
3.2.1 and older
Fixed in
3.3.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The NGG Smart Image Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'hr_SIS_nextgen_searchbox' shortcode in all versions up to, and including, 3.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13658Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
NGG Smart Image Search vulnerability status badge
<a href="https://laskyr.com/plugins/ngg-smart-image-search"><img src="https://laskyr.com/plugins/ngg-smart-image-search/badge.svg" alt="NGG Smart Image Search vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit