Skip to content
Laskyr

Plugins · nextend-facebook-connect · data as of 2026-11-04

Is Nextend Social Login and Register safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.26)

As of 2026-11-04. 6 issues are on record for older versions; version 3.1.22 or newer fixes all of them that state a fix.

Latest version
3.1.26
Last updated
2026-07-28
Active installs
200,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

One click registration & login plugin for Facebook, Google, X (formerly Twitter) and more. Quick setup and easy configuration. — by Nextendweb

What to do

  1. Update to the latest version (3.1.26). Anything older than 3.1.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get nextend-facebook-connect --field=version shows what you run; wp plugin update nextend-facebook-connect updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-13737 · published 2025-11-28

Cross-site request forgery (CSRF) in Nextend Social Login and Register (3.1.21 and older)

Affected
3.1.21 and older
Fixed in
3.1.22 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Nextend Social Login and Register plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.21. This is due to missing or incorrect nonce validation on the 'unlinkUser' function. This makes it possible for unauthenticated attackers to unlink the user's social login via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-13737Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-58031 · published 2025-09-22

Stored cross-site scripting (XSS) in Nextend Social Login and Register (3.1.19 and older)

Affected
3.1.19 and older
Fixed in
3.1.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nextendweb Nextend Facebook Connect nextend-facebook-connect allows Stored XSS.This issue affects Nextend Facebook Connect : from n/a through <= 3.1.19.

NVD CVE-2025-58031Patchstack advisory

critical 9.8 CVE-2024-9893 · published 2024-10-16

Authentication bypass in Nextend Social Login and Register (3.1.14 and older)

Affected
3.1.14 and older
Fixed in
3.1.15 *
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Wordfence
Details from the advisory

The Nextend Social Login Pro plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 3.1.14. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email and the user does not have an already-existing account for the service returning the token.

NVD CVE-2024-9893Wordfence advisorywordpress.orgnextendweb.com

medium 5.4 CVE-2024-1775 · published 2024-03-02

Cross-site request forgery (CSRF) in Nextend Social Login and Register (3.1.12 and older)

Affected
3.1.12 and older
Fixed in
3.1.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Nextend Social Login and Register plugin for WordPress is vulnerable to a self-based Reflected Cross-Site Scripting via the ‘error_description’ parameter in all versions up to, and including, 3.1.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers, with access to a subscriber-level account, to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. NOTE: This vulnerability can be successfully exploited on a vulnerable WordPress instance against an OAuth pre-authenticated higher-level user (e.g., administrator) by leveraging a cross-site request forgery in conjunction with a certain social engineering technique to achieve a critical impact scenario (cross-site scripting to administrator-level account creation). However, successful exploitation requires "Debug mode" to be enabled in the plugin's "Global Settings".

NVD CVE-2024-1775Wordfence advisoryCode change (fix)

medium 4.3 CVE-2015-4413 · published 2015-06-24

Cross-site scripting (XSS) in Nextend Social Login and Register (older than 1.5.6)

Affected
older than 1.5.6
Fixed in
1.5.6
Range from
advisory text · score by NVD
Details from the advisory

Cross-site scripting (XSS) vulnerability in the new_fb_sign_button function in nextend-facebook-connect.php in Nextend Facebook Connect plugin before 1.5.6 for WordPress allows remote attackers to inject arbitrary web script or HTML via the redirect_to parameter.

NVD CVE-2015-4413Code change (fix)wordpress.orgpacketstormsecurity.comseclists.orgsecurityfocus.com

medium 4.3 CVE-2014-8800 · published 2014-12-05

Cross-site scripting (XSS) in Nextend Social Login and Register (1.5.0 and older)

Affected
1.5.0 and older
Fixed in
1.6.0 *
Range from
NVD analysis · score by NVD
Details from the advisory

Cross-site scripting (XSS) vulnerability in nextend-facebook-settings.php in the Nextend Facebook Connect plugin before 1.5.1 for WordPress allows remote attackers to inject arbitrary web script or HTML via the fb_login_button parameter in a newfb_update_options action.

NVD CVE-2014-8800wordpress.orgosvdb.orgsecurity.szurek.plexploit-db.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Nextend Social Login and Register vulnerability status badge
<a href="https://laskyr.com/plugins/nextend-facebook-connect"><img src="https://laskyr.com/plugins/nextend-facebook-connect/badge.svg" alt="Nextend Social Login and Register vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit