Skip to content
Laskyr

Plugins · nextcart-woocommerce-migration · data as of 2026-11-04

Is Next-Cart Store to WooCommerce Migration safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.11)

As of 2026-11-04. 3 issues are on record for older versions; version 3.9.9 or newer fixes all of them that state a fix.

Latest version
3.9.11
Last updated
2026-10-16
Active installs
100+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Migrate products, customers, orders, blog posts, and other data from 80+ eCommerce platforms to WooCommerce and WordPress in a few clicks. — by Martin Nguyen

What to do

  1. Update to the latest version (3.9.11). Anything older than 3.9.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get nextcart-woocommerce-migration --field=version shows what you run; wp plugin update nextcart-woocommerce-migration updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-76009 · published 2026-09-09

Arbitrary file deletion in Next-Cart Store to WooCommerce Migration (3.9.8 and older)

Affected
3.9.8 and older
Fixed in
3.9.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Next-Cart Store to WooCommerce Migration plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 3.9.8 via the `NCWM_Kitconnect::run()` function. This is due to the plugin registering the `/wp-json/next_cart/v1/migration` REST route with `permission_callback` set to `__return_true` and relying on a hardcoded fallback value of `__token__` in `get_option('nextcart_token', '__token__')` when the `nextcart_token` option has not yet been written to the database. This makes it possible for unauthenticated attackers to bypass authentication to the migration endpoint by supplying the literal string `__token__` as the token, gaining access to privileged handlers that pass attacker-controlled SQL directly to `$wpdb->query()` and `$wpdb->get_results()` — enabling arbitrary SQL execution including administrator account creation — and pass an attacker-controlled path to `unlink()`, enabling arbitrary file deletion and full site takeover. The hardcoded fallback is reachable whenever the `nextcart_token` option has not yet been populated, which occurs after WP-CLI, network, or programmatic plugin activation without a subsequent authenticated `wp-admin` visit, as token generation is deferred to `admin_init` via `register_settings()`.

NVD CVE-2026-76009Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2025-30807 · published 2025-04-01

SQL injection in Next-Cart Store to WooCommerce Migration (3.9.4 and older)

Affected
3.9.4 and older
Fixed in
3.9.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Martin Nguyen Next-Cart Store to WooCommerce Migration nextcart-woocommerce-migration allows SQL Injection.This issue affects Next-Cart Store to WooCommerce Migration: from n/a through <= 3.9.4.

NVD CVE-2025-30807Patchstack advisory

medium 6.1 CVE-2024-11687 · published 2024-12-06

Reflected cross-site scripting (XSS) in Next-Cart Store to WooCommerce Migration (3.9.2 and older)

Affected
3.9.2 and older
Fixed in
3.9.9 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Next-Cart Store to WooCommerce Migration plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'page' parameter in all versions up to, and including, 3.9.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-11687Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Next-Cart Store to WooCommerce Migration vulnerability status badge
<a href="https://laskyr.com/plugins/nextcart-woocommerce-migration"><img src="https://laskyr.com/plugins/nextcart-woocommerce-migration/badge.svg" alt="Next-Cart Store to WooCommerce Migration vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit