Skip to content
Laskyr

Plugins · newsmanapp · data as of 2026-11-04

Is NewsmanApp safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.32)

As of 2026-11-04. 3 issues are on record for older versions; version 3.7.32 or newer fixes all of them that state a fix.

Latest version
3.7.32
Last updated
2026-10-26
Active installs
500+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Email & SMS marketing for your store: subscription forms, list sync, newsletters, campaigns, automations and analytics via the NewsMAN platform. — by NewsMAN

What to do

  1. Update to the latest version (3.7.32). Anything older than 3.7.32 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get newsmanapp --field=version shows what you run; wp plugin update newsmanapp updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-115821 · published 2026-10-29

Stored cross-site scripting (XSS) in NewsmanApp (3.7.29 and older)

Affected
3.7.29 and older
Fixed in
3.7.32 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The NewsmanApp plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'billing_first_name, billing_last_name' parameter in all versions up to, and including, 3.7.29 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the Newsman Remarketing feature is enabled and a non-empty Remarketing ID is configured in the plugin settings.

NVD CVE-2026-115821Wordfence advisoryCode change (fix)github.comPlugin source

high 7.1 CVE-2025-60164 · published 2025-09-26

Cross-site request forgery (CSRF) in NewsmanApp (2.7.7 and older)

Affected
2.7.7 and older
Fixed in
3.0.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in NewsMAN NewsmanApp newsmanapp allows Stored XSS.This issue affects NewsmanApp: from n/a through <= 2.7.7.

NVD CVE-2025-60164Patchstack advisory

medium 6.4 CVE-2024-11767 · published 2024-12-13

Stored cross-site scripting (XSS) in NewsmanApp (2.7.6 and older)

Affected
2.7.6 and older
Fixed in
3.6.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The NewsmanApp plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'newsman_subscribe_widget' shortcode in all versions up to, and including, 2.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11767Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
NewsmanApp vulnerability status badge
<a href="https://laskyr.com/plugins/newsmanapp"><img src="https://laskyr.com/plugins/newsmanapp/badge.svg" alt="NewsmanApp vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit