Skip to content
Laskyr

Plugins · newsletter-optin-box · data as of 2026-11-04

Is Noptin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.3)

As of 2026-11-04. 4 issues are on record for older versions; version 4.4.0 or newer fixes all of them that state a fix.

Latest version
4.4.3
Last updated
2026-10-28
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Fast, lightweight newsletter plugin. Send new post notifications and newsletters, collect unlimited subscribers, and automate WordPress emails. ★★★★★ — by Noptin Newsletter Team

What to do

  1. Update to the latest version (4.4.3). Anything older than 4.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get newsletter-optin-box --field=version shows what you run; wp plugin update newsletter-optin-box updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-103482 · published 2026-10-10

Stored cross-site scripting (XSS) in Noptin (4.3.10 and older)

Affected
4.3.10 and older
Fixed in
4.4.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Simple Newsletter Plugin – Noptin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'noptin_fields[<custom_field_merge_tag>] (e.g. first_name)' parameter in all versions up to, and including, 4.3.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The attack chain requires a published campaign post whose body contains a [[subscriber.*]] merge tag; the unauthenticated attacker first POSTs the entity-encoded payload to the public manage_preferences form (which issues its own nonce on the same page), then pivots execution by embedding their confirm_key in a campaign preview URL sent to a privileged user via social engineering.

NVD CVE-2026-103482Wordfence advisorygithub.comPlugin source

medium 5.9 CVE-2025-49871 · published 2025-06-17

Stored cross-site scripting (XSS) in Noptin (3.8.7 and older)

Affected
3.8.7 and older
Fixed in
4.0.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Noptin Newsletter Team Noptin newsletter-optin-box allows Stored XSS.This issue affects Noptin: from n/a through <= 3.8.7.

NVD CVE-2025-49871Patchstack advisory

medium 5.3 CVE-2024-37456 · published 2024-11-01

Missing authorization check in Noptin (3.4.2 and older)

Affected
3.4.2 and older
Fixed in
3.4.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Noptin Newsletter Noptin allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Noptin: from n/a through 3.4.2.

NVD CVE-2024-37456Patchstack advisory

critical 9.8 CVE-2022-46803 · published 2023-11-07

CSV injection in Noptin (1.9.5 and older)

Affected
1.9.5 and older
Fixed in
1.10.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Formula Elements in a CSV File vulnerability in Noptin Newsletter Simple Newsletter Plugin – Noptin.This issue affects Simple Newsletter Plugin – Noptin: from n/a through 1.9.5.

NVD CVE-2022-46803Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Noptin vulnerability status badge
<a href="https://laskyr.com/plugins/newsletter-optin-box"><img src="https://laskyr.com/plugins/newsletter-optin-box/badge.svg" alt="Noptin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit