Plugins · news-element · data as of 2026-11-04
Is News Element Elementor Blog Magazine safe? Known vulnerabilities and latest version
- Latest version
- 1.0.9
- Last updated
- 2026-08-13
- Active installs
- 400+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.9.11 · PHP 7.0+
Create News, Magazine and Blogs with grid, slider, hero, header-footer etc. — by webangon
What to do
- There is no fixed version yet. If you can live without News Element Elementor Blog Magazine for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get news-element --field=version shows what you run; wp plugin update news-element updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-2284 · published 2026-02-19
Missing authorization check in News Element Elementor Blog Magazine (1.0.8 and older)
- Affected
- 1.0.8 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The News Element Elementor Blog Magazine plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.0.8. This is due to a missing capability check and nonce verification on the 'ne_clean_data' AJAX action. This makes it possible for authenticated attackers, with Subscriber-level access and above, to truncate 8 core WordPress database tables (posts, comments, terms, term_relationships, term_taxonomy, postmeta, commentmeta, termmeta) and delete the entire WordPress uploads directory, resulting in complete data loss.
medium 6.5 affects latest 1.0.9 CVE-2025-32191 · published 2025-04-04
Cross-site scripting (XSS) in News Element Elementor Blog Magazine (1.0.9 and older)
- Affected
- 1.0.9 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in webangon News Element Elementor Blog Magazine news-element allows DOM-Based XSS.This issue affects News Element Elementor Blog Magazine: from n/a through <= 1.0.9.
critical 9.8 CVE-2024-6459 · published 2024-08-17
File inclusion in News Element Elementor Blog Magazine (older than 1.0.6)
- Affected
- older than 1.0.6
- Fixed in
- 1.0.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The News Element Elementor Blog Magazine WordPress plugin before 1.0.6 is vulnerable to Local File Inclusion via the template parameter. This makes it possible for unauthenticated attacker to include and execute PHP files on the server, allowing the execution of any PHP code in those files.
Recent activity
- 2026-08-13 — latest release on wordpress.org (1.0.9).
- 2026-02-19 — Missing authorization check disclosed (CVE-2026-2284), fix version not stated.
- 2025-04-04 — Cross-site scripting (XSS) disclosed (CVE-2025-32191), no fix listed yet.
- 2024-08-17 — File inclusion disclosed (CVE-2024-6459), fixed in 1.0.6.
Get an email when News Element Elementor Blog Magazine has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for News Element Elementor Blog Magazine (news-element) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/news-element (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/news-element"><img src="https://laskyr.com/plugins/news-element/badge.svg" alt="News Element Elementor Blog Magazine vulnerability status"></a>