Skip to content
Laskyr

Plugins · new-contact-form-widget · data as of 2026-11-04

Is Contact Form Widget safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.3)

As of 2026-11-04. 5 issues are on record for older versions; version 1.5.2 or newer fixes all of them that state a fix.

Latest version
1.5.3
Last updated
2026-10-02
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8

Create responsive contact forms with stored query table management. Easy contact form shortcode and widget for inquiries and lead generation. — by A WP Life

What to do

  1. Update to the latest version (1.5.3). Anything older than 1.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get new-contact-form-widget --field=version shows what you run; wp plugin update new-contact-form-widget updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-62134 · published 2025-12-31

Cross-site request forgery (CSRF) in Contact Form Widget (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in A WP Life Contact Form Widget new-contact-form-widget allows Cross Site Request Forgery.This issue affects Contact Form Widget: from n/a through <= 1.5.1.

NVD CVE-2025-62134Patchstack advisory

high 7.4 CVE-2025-47491 · published 2025-05-07

Cross-site request forgery (CSRF) in Contact Form Widget (1.4.6 and older)

Affected
1.4.6 and older
Fixed in
1.4.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in A WP Life Contact Form Widget new-contact-form-widget allows Cross Site Request Forgery.This issue affects Contact Form Widget: from n/a through <= 1.4.6.

NVD CVE-2025-47491Patchstack advisory

medium 5.4 CVE-2024-48037 · published 2024-10-17

Cross-site request forgery (CSRF) in Contact Form Widget (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in A WP Life Contact Form Widget new-contact-form-widget allows Cross Site Request Forgery.This issue affects Contact Form Widget: from n/a through <= 1.4.2.

NVD CVE-2024-48037Patchstack advisory

medium 5.3 CVE-2024-34754 · published 2024-06-03

Information disclosure in Contact Form Widget (1.3.9 and older)

Affected
1.3.9 and older
Fixed in
1.4.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in A WP Life Contact Form Widget.This issue affects Contact Form Widget: from n/a through 1.3.9.

NVD CVE-2024-34754Patchstack advisory

critical 9.8 CVE-2019-17072 · published 2019-10-10

SQL injection in Contact Form Widget (1.0.9 only)

Affected
1.0.9 only
Fixed in
1.1.0 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The new-contact-form-widget (aka Contact Form Widget - Contact Query, Form Maker) plugin 1.0.9 for WordPress has SQL Injection via all-query-page.php.

NVD CVE-2019-17072wordpress.orggist.github.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Contact Form Widget vulnerability status badge
<a href="https://laskyr.com/plugins/new-contact-form-widget"><img src="https://laskyr.com/plugins/new-contact-form-widget/badge.svg" alt="Contact Form Widget vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit