Skip to content
Laskyr

Plugins · netgsm · data as of 2026-11-04

Is Netgsm safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.10.4)

As of 2026-11-04. 6 issues are on record for older versions; version 2.10.2 or newer fixes all of them that state a fix.

Latest version
2.10.4
Last updated
2026-10-23
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.4.33+

Netgsm wordpress eklentisi ile kullanıcılarınıza sms uzaklığında kalın. — by netgsm

What to do

  1. Update to the latest version (2.10.4). Anything older than 2.10.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get netgsm --field=version shows what you run; wp plugin update netgsm updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-95514 · published 2026-09-23

Security issue in Netgsm (2.10.0 and older)

Affected
2.10.0 and older
Fixed in
2.10.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in Netgsm <= 2.10.0 versions.

NVD CVE-2026-95514Patchstack advisory

high 7.1 CVE-2025-68010 · published 2026-01-22

Reflected cross-site scripting (XSS) in Netgsm (2.9.63 and older)

Affected
2.9.63 and older
Fixed in
2.9.64
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in netgsm Netgsm netgsm allows Reflected XSS.This issue affects Netgsm: from n/a through <= 2.9.63.

NVD CVE-2025-68010Patchstack advisory

medium 4.3 CVE-2025-60143 · published 2025-09-26

Missing authorization check in Netgsm (2.9.69 and older)

Affected
2.9.69 and older
Fixed in
2.9.70 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in netgsm Netgsm netgsm allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Netgsm: from n/a through <= 2.9.69.

NVD CVE-2025-60143Patchstack advisory

medium 6.3 CVE-2024-4746 · published 2024-06-10

Missing authorization check in Netgsm (2.9.32 and older)

Affected
2.9.32 and older
Fixed in
2.9.33
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in netgsm Netgsm netgsm allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Netgsm: from n/a through <= 2.9.32.

NVD CVE-2024-4746Patchstack advisoryPatchstack advisory

critical 9.8 CVE-2024-35672 · published 2024-06-04

Missing authorization check in Netgsm (2.9.19 and older)

Affected
2.9.19 and older
Fixed in
2.9.20
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Netgsm.This issue affects Netgsm: from n/a through 2.9.19.

NVD CVE-2024-35672Patchstack advisory

high 7.1 CVE-2024-32544 · published 2024-04-17

Reflected cross-site scripting (XSS) in Netgsm (2.8 and older)

Affected
2.8 and older
Fixed in
2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Netgsm allows Reflected XSS.This issue affects Netgsm: from n/a through 2.8.

NVD CVE-2024-32544Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Netgsm vulnerability status badge
<a href="https://laskyr.com/plugins/netgsm"><img src="https://laskyr.com/plugins/netgsm/badge.svg" alt="Netgsm vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit