Plugins · netcash-pay-now-payment-gateway-for-woocommerce · data as of 2026-11-04
Is Netcash WooCommerce Payment Gateway safe? Known vulnerabilities and latest version
- Latest version
- 4.1.6
- Last updated
- 2026-08-21
- Active installs
- 300+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
This is the Netcash Pay Now plugin for WooCommerce giving you the ability to accept recurring and credit card payments in your WooCommerce store. — by netcashpaynow
What to do
- Update to the latest version (4.1.6). Anything older than 4.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get netcash-pay-now-payment-gateway-for-woocommerce --field=version shows what you run; wp plugin update netcash-pay-now-payment-gateway-for-woocommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-14880 · published 2026-01-14
Missing authorization check in Netcash WooCommerce Payment Gateway (4.1.3 and older)
- Affected
- 4.1.3 and older
- Fixed in
- 4.1.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Netcash WooCommerce Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the handle_return_url function in all versions up to, and including, 4.1.3. This makes it possible for unauthenticated attackers to mark any WooCommerce order as processing/completed.
NVD CVE-2025-14880Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-21 — latest release on wordpress.org (4.1.6).
- 2026-01-14 — Missing authorization check disclosed (CVE-2025-14880), fixed in 4.1.4.
Get an email when Netcash WooCommerce Payment Gateway has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Netcash WooCommerce Payment Gateway (netcash-pay-now-payment-gateway-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/netcash-pay-now-payment-gateway-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/netcash-pay-now-payment-gateway-for-woocommerce"><img src="https://laskyr.com/plugins/netcash-pay-now-payment-gateway-for-woocommerce/badge.svg" alt="Netcash WooCommerce Payment Gateway vulnerability status"></a>