Skip to content
Laskyr

Plugins · nelio-popups · data as of 2026-11-04

Is Nelio Popups safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.3.6 or newer fixes all of them that state a fix.

Latest version
1.5.0
Last updated
2026-08-18
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

An intuitive popup designer based on open WordPress technologies — by Nelio Software

What to do

  1. Update to the latest version (1.5.0). Anything older than 1.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get nelio-popups --field=version shows what you run; wp plugin update nelio-popups updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-25016 · published 2026-02-03

Missing authorization check in Nelio Popups (1.3.5 and older)

Affected
1.3.5 and older
Fixed in
1.3.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nelio Software Nelio Popups nelio-popups allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Nelio Popups: from n/a through <= 1.3.5.

NVD CVE-2026-25016Patchstack advisory

medium 6.5 CVE-2025-66111 · published 2025-11-21

Stored cross-site scripting (XSS) in Nelio Popups (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nelio Software Nelio Popups nelio-popups allows Stored XSS.This issue affects Nelio Popups: from n/a through <= 1.3.0.

NVD CVE-2025-66111Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Nelio Popups vulnerability status badge
<a href="https://laskyr.com/plugins/nelio-popups"><img src="https://laskyr.com/plugins/nelio-popups/badge.svg" alt="Nelio Popups vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit