Skip to content
Laskyr

Plugins · nelio-content · data as of 2026-11-04

Is Nelio Content safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.5.2)

As of 2026-11-04. 6 issues are on record for older versions; version 4.5.1 or newer fixes all of them that state a fix.

Latest version
4.5.2
Last updated
2026-10-21
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WordPress editorial calendar and social media auto-posting plugin. Schedule posts, share to social networks, and streamline content workflows. — by Nelio Software

What to do

  1. Update to the latest version (4.5.2). Anything older than 4.5.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get nelio-content --field=version shows what you run; wp plugin update nelio-content updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-94505 · published 2026-10-03

Missing authorization check in Nelio Content (4.5.0 and older)

Affected
4.5.0 and older
Fixed in
4.5.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Nelio Content – Editorial Calendar & Social Media Auto-Posting plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.5.0 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with contributor-level access and above, to permanently delete any reusable social message (nc_reusable_social post), including those authored by administrators or other privileged users.

NVD CVE-2026-94505Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-57648 · published 2026-06-26

Missing authorization check in Nelio Content (4.3.4 and older)

Affected
4.3.4 and older
Fixed in
4.3.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Broken Access Control in Nelio Content <= 4.3.4 versions.

NVD CVE-2026-57648Patchstack advisory

medium 4.9 CVE-2026-39521 · published 2026-04-08

Server-side request forgery (SSRF) in Nelio Content (4.3.1 and older)

Affected
4.3.1 and older
Fixed in
4.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Nelio Software Nelio Content nelio-content allows Server Side Request Forgery.This issue affects Nelio Content: from n/a through <= 4.3.1.

NVD CVE-2026-39521Patchstack advisory

high 8.5 CVE-2026-24572 · published 2026-01-23

SQL injection in Nelio Content (4.2.0 and older)

Affected
4.2.0 and older
Fixed in
4.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Nelio Software Nelio Content nelio-content allows Blind SQL Injection.This issue affects Nelio Content: from n/a through <= 4.2.0.

NVD CVE-2026-24572Patchstack advisory

medium 6.5 CVE-2025-62927 · published 2025-10-27

Missing authorization check in Nelio Content (4.0.5 and older)

Affected
4.0.5 and older
Fixed in
4.0.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Nelio Software Nelio Content nelio-content allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Nelio Content: from n/a through <= 4.0.5.

NVD CVE-2025-62927Patchstack advisory

medium 4.9 CVE-2024-30531 · published 2024-04-02

Server-side request forgery (SSRF) in Nelio Content (3.2.0 and older)

Affected
3.2.0 and older
Fixed in
3.2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Nelio Software Nelio Content.This issue affects Nelio Content: from n/a through 3.2.0.

NVD CVE-2024-30531Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Nelio Content vulnerability status badge
<a href="https://laskyr.com/plugins/nelio-content"><img src="https://laskyr.com/plugins/nelio-content/badge.svg" alt="Nelio Content vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit