Plugins · nd-shortcodes · data as of 2026-11-04
Is ND Shortcodes safe? Known vulnerabilities and latest version
- Latest version
- 7.8
- Last updated
- 2025-03-18
- Active installs
- 20,000+
- Known issues on record
- 4
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11
The plugin adds some useful components to your page builder ( Elementor or WP Bakery Page Builder ). All components are full responsive and retina rea … — by nicdark
What to do
- There is no fixed version yet. If you can live without ND Shortcodes for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get nd-shortcodes --field=version shows what you run; wp plugin update nd-shortcodes updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 7.8 CVE-2026-114702 · published 2026-10-22
Stored cross-site scripting (XSS) in ND Shortcodes (7.8 and older)
- Affected
- 7.8 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in nicdark ND Shortcodes For Visual Composer nd-shortcodes allows Stored XSS.This issue affects ND Shortcodes For Visual Composer: from n/a through 7.8.
medium 5.4 CVE-2024-5220 · published 2024-05-25
Stored cross-site scripting (XSS) in ND Shortcodes (7.5 and older)
- Affected
- 7.5 and older
- Fixed in
- 7.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The ND Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's upload feature in all versions up to, and including, 7.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-5220Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2022-4623 · published 2023-07-04
Stored cross-site scripting (XSS) in ND Shortcodes (older than 7.0)
- Affected
- older than 7.0
- Fixed in
- 7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The ND Shortcodes WordPress plugin before 7.0 does not validate and escape numerous of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
high 8.8 CVE-2023-1273 · published 2023-07-04
File inclusion in ND Shortcodes (older than 7.0)
- Affected
- older than 7.0
- Fixed in
- 7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The ND Shortcodes WordPress plugin before 7.0 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users such as subscriber to perform LFI attacks
Recent activity
- 2025-03-18 — latest release on wordpress.org (7.8).
- 2026-10-22 — Stored cross-site scripting (XSS) disclosed (CVE-2026-114702), no fix listed yet.
- 2024-05-25 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5220), fixed in 7.6.
- 2023-07-04 — Stored cross-site scripting (XSS) disclosed (CVE-2022-4623), fixed in 7.0.
Get an email when ND Shortcodes has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ND Shortcodes (nd-shortcodes) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/nd-shortcodes (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/nd-shortcodes"><img src="https://laskyr.com/plugins/nd-shortcodes/badge.svg" alt="ND Shortcodes vulnerability status"></a>