Plugins · mystickymenu · data as of 2026-11-04
Is My Sticky Bar safe? Known vulnerabilities and latest version
- Latest version
- 2.9.3
- Last updated
- 2026-10-28
- Active installs
- 100,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Create a welcome notification bar for your website. Also, My Sticky Bar plugin can make your menu or header sticky to the top when scrolled 📌 — by Premio
What to do
- Update to the latest version (2.9.3). Anything older than 2.8.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mystickymenu --field=version shows what you run; wp plugin update mystickymenu updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-3657 · published 2026-03-12
SQL injection in My Sticky Bar (2.8.6 and older)
- Affected
- 2.8.6 and older
- Fixed in
- 2.8.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The My Sticky Bar plugin for WordPress is vulnerable to SQL injection via the `stickymenu_contact_lead_form` AJAX action in all versions up to, and including, 2.8.6. This is due to the handler using attacker-controlled POST parameter names directly as SQL column identifiers in `$wpdb->insert()`. While parameter values are sanitized with `esc_sql()` and `sanitize_text_field()`, the parameter keys are used as-is to build the column list in the INSERT statement. This makes it possible for unauthenticated attackers to inject SQL via crafted parameter names, enabling blind time-based data extraction from the database.
NVD CVE-2026-3657Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2023-7048 · published 2024-01-11
Cross-site request forgery (CSRF) in My Sticky Bar (2.6.6 and older)
- Affected
- 2.6.6 and older
- Fixed in
- 2.6.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The My Sticky Bar plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.6. This is due to missing or incorrect nonce validation in mystickymenu-contact-leads.php. This makes it possible for unauthenticated attackers to trigger the export of a CSV file containing contact leads via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Because the CSV file is exported to a public location, it can be downloaded during a very short window of time before it is automatically deleted by the export function.
Recent activity
- 2026-10-28 — latest release on wordpress.org (2.9.3).
- 2026-03-12 — SQL injection disclosed (CVE-2026-3657), fixed in 2.8.7.
- 2024-01-11 — Cross-site request forgery (CSRF) disclosed (CVE-2023-7048), fixed in 2.6.7.
Get an email when My Sticky Bar has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for My Sticky Bar (mystickymenu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Premio (5 tracked)
Types found in this plugin: SQL injection (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mystickymenu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mystickymenu"><img src="https://laskyr.com/plugins/mystickymenu/badge.svg" alt="My Sticky Bar vulnerability status"></a>