Skip to content
Laskyr

Plugins · mycryptocheckout · data as of 2026-11-04

Is MyCryptoCheckout safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.172)

As of 2026-11-04. 3 issues are on record for older versions; version 2.162 or newer fixes all of them that state a fix.

Latest version
2.172
Last updated
2026-08-19
Active installs
8,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Crypto payment gateway for WooCommerce and Easy Digital Downloads. Accept 100+ coins: Bitcoin, Ethereum, BNB, Solana. Peer2Peer transactions. — by edward_plainview

What to do

  1. Update to the latest version (2.172). Anything older than 2.162 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mycryptocheckout --field=version shows what you run; wp plugin update mycryptocheckout updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-45209 · published 2026-05-25

Missing authorization check in MyCryptoCheckout (2.161 and older)

Affected
2.161 and older
Fixed in
2.162
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in edward_plainview MyCryptoCheckout allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects MyCryptoCheckout: from n/a through 2.161.

NVD CVE-2026-45209Patchstack advisory

high 8.8 CVE-2023-41693 · published 2023-10-03

Cross-site request forgery (CSRF) in MyCryptoCheckout (2.125 and older)

Affected
2.125 and older
Fixed in
2.126
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in edward_plainview MyCryptoCheckout plugin <= 2.125 versions.

NVD CVE-2023-41693Patchstack advisory

medium 6.1 CVE-2023-1546 · published 2023-05-02

Reflected cross-site scripting (XSS) in MyCryptoCheckout (older than 2.124)

Affected
older than 2.124
Fixed in
2.124
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MyCryptoCheckout WordPress plugin before 2.124 does not escape some URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting

NVD CVE-2023-1546WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MyCryptoCheckout vulnerability status badge
<a href="https://laskyr.com/plugins/mycryptocheckout"><img src="https://laskyr.com/plugins/mycryptocheckout/badge.svg" alt="MyCryptoCheckout vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit