Skip to content
Laskyr

Plugins · myagileprivacy · data as of 2026-11-04

Is My Agile Privacy® safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.3.7 or newer fixes all of them that state a fix.

Latest version
3.4.1
Last updated
2026-10-28
Active installs
7,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Effortlessly set up cookie notices and privacy policies. Avoid fines by staying compliant with GDPR, nFADP, PIPEDA, LGPD, CCPA/CPRA and 19 more. — by Formula Agile

What to do

  1. Update to the latest version (3.4.1). Anything older than 3.3.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get myagileprivacy --field=version shows what you run; wp plugin update myagileprivacy updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-17587 · published 2026-08-25

Missing authorization check in My Agile Privacy® (3.3.6 and older)

Affected
3.3.6 and older
Fixed in
3.3.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The My Agile Privacy® – CMP, Cookie Consent & Privacy Tools plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.3.6. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to modify plugin settings including missing_cookie_shield, cookie_shield_running, cmode_v2_js_on_error, cmode_v2_js_error_code, and cmode_v2_js_error_motivation stored in the plugin's settings key.

NVD CVE-2026-17587Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-51404 · published 2024-02-10

Stored cross-site scripting (XSS) in My Agile Privacy® (2.1.7 and older)

Affected
2.1.7 and older
Fixed in
2.1.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MyAgilePrivacy My Agile Privacy – The only GDPR solution for WordPress that you can truly trust allows Stored XSS.This issue affects My Agile Privacy – The only GDPR solution for WordPress that you can truly trust: from n/a through 2.1.7.

NVD CVE-2023-51404Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
My Agile Privacy® vulnerability status badge
<a href="https://laskyr.com/plugins/myagileprivacy"><img src="https://laskyr.com/plugins/myagileprivacy/badge.svg" alt="My Agile Privacy® vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit