Skip to content
Laskyr

Plugins · my-tickets · data as of 2026-11-04

Is My Tickets safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.2)

As of 2026-11-04. 9 issues are on record for older versions; version 2.1.2 or newer fixes all of them that state a fix.

Latest version
2.3.2
Last updated
2026-10-14
Active installs
600+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

My Tickets is a simple, flexible platform for selling event tickets with WordPress. — by Joe Dolson

What to do

  1. Update to the latest version (2.3.2). Anything older than 2.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get my-tickets --field=version shows what you run; wp plugin update my-tickets updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-32492 · published 2026-03-25

Authentication bypass in My Tickets (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.1.2
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Patchstack
Details from the advisory

Authentication Bypass by Spoofing vulnerability in Joe Dolson My Tickets my-tickets allows Identity Spoofing.This issue affects My Tickets: from n/a through <= 2.1.1.

NVD CVE-2026-32492Patchstack advisory

high 7.5 CVE-2026-27406 · published 2026-03-05

Information disclosure in My Tickets (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Joe Dolson My Tickets my-tickets allows Retrieve Embedded Sensitive Data.This issue affects My Tickets: from n/a through <= 2.1.0.

NVD CVE-2026-27406Patchstack advisory

medium 4.3 CVE-2025-64257 · published 2025-12-09

Missing authorization check in My Tickets (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Joe Dolson My Tickets my-tickets allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects My Tickets: from n/a through <= 2.1.0.

NVD CVE-2025-64257Patchstack advisory

medium 6.5 CVE-2025-58988 · published 2025-09-09

Stored cross-site scripting (XSS) in My Tickets (2.0.22 and older)

Affected
2.0.22 and older
Fixed in
2.0.23
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Joe Dolson My Tickets my-tickets allows Stored XSS.This issue affects My Tickets: from n/a through <= 2.0.22.

NVD CVE-2025-58988Patchstack advisory

high 8.8 CVE-2025-3761 · published 2025-04-24

Privilege escalation in My Tickets (2.0.16 and older)

Affected
2.0.16 and older
Fixed in
2.0.23 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The My Tickets – Accessible Event Ticketing plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.0.16. This is due to the mt_save_profile() function not appropriately restricting access to unauthorized users to update roles. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to that of an administrator.

NVD CVE-2025-3761Wordfence advisoryCode change (fix)

high 7.5 CVE-2025-22717 · published 2025-01-21

Missing authorization check in My Tickets (2.0.9 and older)

Affected
2.0.9 and older
Fixed in
2.0.10
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Joe Dolson My Tickets my-tickets allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects My Tickets: from n/a through <= 2.0.9.

NVD CVE-2025-22717Patchstack advisory

high 7.5 CVE-2023-23988 · published 2024-05-17

Missing authorization check in My Tickets (1.9.11 and older)

Affected
1.9.11 and older
Fixed in
1.9.12
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Joseph C Dolson My Tickets.This issue affects My Tickets: from n/a through 1.9.11.

NVD CVE-2023-23988Patchstack advisory

high 8.8 CVE-2022-47440 · published 2023-03-13

Cross-site request forgery (CSRF) in My Tickets (1.9.10 and older)

Affected
1.9.10 and older
Fixed in
1.9.11
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Joseph C Dolson My Tickets plugin <= 1.9.10 versions.

NVD CVE-2022-47440Patchstack advisory

medium 6.1 CVE-2021-24796 · published 2021-11-17

Cross-site scripting (XSS) in My Tickets (older than 1.8.31)

Affected
older than 1.8.31
Fixed in
1.8.31
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The My Tickets WordPress plugin before 1.8.31 does not properly sanitise and escape the Email field of booked tickets before outputting it in the Payment admin dashboard, which could allow unauthenticated users to perform Cross-Site Scripting attacks against admins

NVD CVE-2021-24796WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
My Tickets vulnerability status badge
<a href="https://laskyr.com/plugins/my-tickets"><img src="https://laskyr.com/plugins/my-tickets/badge.svg" alt="My Tickets vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit