Skip to content
Laskyr

Plugins · mxchat-basic · data as of 2026-11-04

Is MxChat safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.27)

As of 2026-11-04. 4 issues are on record for older versions; version 3.2.26 or newer fixes all of them that state a fix.

Latest version
3.2.27
Last updated
2026-10-24
Active installs
2,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free AI chatbot and content generation for WordPress. Train ChatGPT, Claude, Gemini or Grok on your content. WooCommerce ready with RAG. — by MxChat

What to do

  1. Update to the latest version (3.2.27). Anything older than 3.2.26 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mxchat-basic --field=version shows what you run; wp plugin update mxchat-basic updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-110662 · published 2026-10-28

DOM-based cross-site scripting (XSS) in MxChat (3.2.25 and older)

Affected
3.2.25 and older
Fixed in
3.2.26 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MxChat – AI Chatbot & Content Generation for WordPress plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'feedback' parameter in all versions up to, and including, 3.2.25 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The stored payload is written by any unauthenticated visitor via a single POST to admin-ajax.php and detonates automatically when any administrator next loads the Transcripts page.

NVD CVE-2026-110662Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2026-13005 · published 2026-07-16

Stored cross-site scripting (XSS) in MxChat (3.2.10 and older)

Affected
3.2.10 and older
Fixed in
3.2.11 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MxChat – AI Chatbot & Content Generation for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.2.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-13005Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2025-12585 · published 2025-12-03

Information disclosure in MxChat (2.5.5 and older)

Affected
2.5.5 and older
Fixed in
2.5.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MxChat – AI Chatbot for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.5.5 via upload filenames. This makes it possible for unauthenticated attackers to extract session values that can subsequently be used to access conversation data.

NVD CVE-2025-12585Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

medium 5.3 CVE-2025-10705 · published 2025-10-23

Server-side request forgery (SSRF) in MxChat (2.4.6 and older)

Affected
2.4.6 and older
Fixed in
2.4.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MxChat – AI Chatbot for WordPress plugin for WordPress is vulnerable to Blind Server-Side Request Forgery in all versions up to, and including, 2.4.6. This is due to insufficient validation of user-supplied URLs in the PDF processing functionality. This makes it possible for unauthenticated attackers to make the WordPress server perform HTTP requests to arbitrary destinations via the mxchat_handle_chat_request AJAX action.

NVD CVE-2025-10705Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MxChat vulnerability status badge
<a href="https://laskyr.com/plugins/mxchat-basic"><img src="https://laskyr.com/plugins/mxchat-basic/badge.svg" alt="MxChat vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit