Skip to content
Laskyr

Plugins · music-store · data as of 2026-11-04

Is Music Store safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.8)

As of 2026-11-04. 5 issues are on record for older versions; version 1.4.8 or newer fixes all of them that state a fix.

Latest version
1.4.8
Last updated
2026-10-09
Active installs
200+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Music Store, online store for selling audio files (Ex. music, speeches, narratives), that supports PayPal, Stripe, Square, and other payment gateways. — by codepeople

What to do

  1. Update to the latest version (1.4.8). Anything older than 1.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get music-store --field=version shows what you run; wp plugin update music-store updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-115497 · published 2026-10-23

Path traversal / file read in Music Store (1.4.7 and older)

Affected
1.4.7 and older
Fixed in
1.4.8 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Music Store – WordPress eCommerce plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 1.4.7 via the 'f' parameter parameter. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. Exploitation requires a valid purchase_id token, which any user can obtain by making a single low-cost purchase or receiving a shared download link.

NVD CVE-2026-115497Wordfence advisoryPlugin source

high 8.6 CVE-2026-82304 · published 2026-09-05

SQL injection in Music Store (1.0.245 up to (not including) 1.4.5)

Affected
1.0.245 up to (not including) 1.4.5
Fixed in
1.4.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Music Store WordPress plugin before 1.4.5 does not sanitise and escape user input before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users.

NVD CVE-2026-82304WPScan advisory

high 7.1 CVE-2025-24626 · published 2025-01-27

Reflected cross-site scripting (XSS) in Music Store (1.1.19 and older)

Affected
1.1.19 and older
Fixed in
1.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Music Store music-store allows Reflected XSS.This issue affects Music Store: from n/a through <= 1.1.19.

NVD CVE-2025-24626Patchstack advisory

medium 6.5 CVE-2024-36082 · published 2024-06-07

SQL injection in Music Store (older than 1.1.14)

Affected
older than 1.1.14
Fixed in
1.1.14
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

SQL injection vulnerability in Music Store - WordPress eCommerce versions prior to 1.1.14 allows a remote authenticated attacker with an administrative privilege to execute arbitrary SQL commands. Information stored in the database may be obtained or altered by the attacker.

NVD CVE-2024-36082Code change (fix)wordpress.orgjvn.jp

medium 6.1 CVE-2016-10992 · published 2019-09-17

Cross-site scripting (XSS) in Music Store (1.0.141 and older)

Affected
1.0.141 and older
Fixed in
1.0.240 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The music-store plugin before 1.0.43 for WordPress has XSS via the wp-admin/admin.php?page=music-store-menu-reports from_year parameter.

NVD CVE-2016-10992wordpress.orgpacketstormsecurity.comwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Music Store vulnerability status badge
<a href="https://laskyr.com/plugins/music-store"><img src="https://laskyr.com/plugins/music-store/badge.svg" alt="Music Store vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit