Skip to content
Laskyr

Plugins · music-player-for-woocommerce · data as of 2026-11-04

Is Music Player for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.2)

As of 2026-11-04. 3 issues are on record for older versions; version 1.9.2 or newer fixes all of them that state a fix.

Latest version
1.9.2
Last updated
2026-09-18
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Audio player for WooCommerce products with Dokan & WCFM Marketplace support, plus AI-generated skins. — by codepeople

What to do

  1. Update to the latest version (1.9.2). Anything older than 1.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get music-player-for-woocommerce --field=version shows what you run; wp plugin update music-player-for-woocommerce updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-93624 · published 2026-09-30

PHP object injection in Music Player for WooCommerce (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.9.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in Music Player for WooCommerce <= 1.9.1 versions.

NVD CVE-2026-93624Patchstack advisory

high 7.1 CVE-2026-78283 · published 2026-08-27

Cross-site scripting (XSS) in Music Player for WooCommerce (1.8.9 and older)

Affected
1.8.9 and older
Fixed in
1.9.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Music Player for WooCommerce <= 1.8.9 versions.

NVD CVE-2026-78283Patchstack advisory

medium 5.4 CVE-2025-47472 · published 2025-05-07

Missing authorization check in Music Player for WooCommerce (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in codepeople Music Player for WooCommerce music-player-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Music Player for WooCommerce: from n/a through <= 1.5.1.

NVD CVE-2025-47472Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Music Player for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/music-player-for-woocommerce"><img src="https://laskyr.com/plugins/music-player-for-woocommerce/badge.svg" alt="Music Player for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit