Skip to content
Laskyr

Plugins · multiparcels-shipping-for-woocommerce · data as of 2026-11-04

Is MultiParcels Shipping For WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.30.44)

As of 2026-11-04. 8 issues are on record for older versions; version 1.30.37 or newer fixes all of them that state a fix.

Latest version
1.30.44
Last updated
2026-10-13
Active installs
4,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.12 · PHP 7.4+

Easiest, fastest and the cheapest way to integrate couriers with all deliveries methods to send parcels with just a few button clicks. — by multiparcels

What to do

  1. Update to the latest version (1.30.44). Anything older than 1.30.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get multiparcels-shipping-for-woocommerce --field=version shows what you run; wp plugin update multiparcels-shipping-for-woocommerce updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-66655 · published 2026-08-13

Cross-site scripting (XSS) in MultiParcels Shipping For WooCommerce (1.30.36 and older)

Affected
1.30.36 and older
Fixed in
1.30.37 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in MultiParcels Shipping For WooCommerce <= 1.30.36 versions.

NVD CVE-2026-66655Patchstack advisory

medium 4.3 CVE-2025-62995 · published 2025-12-09

Missing authorization check in MultiParcels Shipping For WooCommerce (1.30.12 and older)

Affected
1.30.12 and older
Fixed in
1.30.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in multiparcels MultiParcels Shipping For WooCommerce multiparcels-shipping-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects MultiParcels Shipping For WooCommerce: from n/a through <= 1.30.12.

NVD CVE-2025-62995Patchstack advisory

medium 4.3 CVE-2024-32095 · published 2024-04-15

Cross-site request forgery (CSRF) in MultiParcels Shipping For WooCommerce (older than 1.16.9)

Affected
older than 1.16.9
Fixed in
1.16.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in MultiParcels MultiParcels Shipping For WooCommerce.This issue affects MultiParcels Shipping For WooCommerce: from n/a before 1.16.9.

NVD CVE-2024-32095Patchstack advisory

medium 6.1 CVE-2023-3954 · published 2023-08-21

Reflected cross-site scripting (XSS) in MultiParcels Shipping For WooCommerce (1.15.2 up to (not including) 1.15.4)

Affected
1.15.2 up to (not including) 1.15.4
Fixed in
1.15.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MultiParcels Shipping For WooCommerce WordPress plugin before 1.15.4 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

NVD CVE-2023-3954WPScan advisory

medium 4.3 CVE-2023-3366 · published 2023-08-21

Cross-site request forgery (CSRF) in MultiParcels Shipping For WooCommerce (older than 1.15.2)

Affected
older than 1.15.2
Fixed in
1.15.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MultiParcels Shipping For WooCommerce WordPress plugin before 1.15.2 does not have CRSF check when deleting a shipment, allowing attackers to make any logged in user, delete arbitrary shipment via a CSRF attack

NVD CVE-2023-3366WPScan advisory

high 8.1 CVE-2023-3365 · published 2023-08-07

Security issue in MultiParcels Shipping For WooCommerce (older than 1.14.14)

Affected
older than 1.14.14
Fixed in
1.14.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MultiParcels Shipping For WooCommerce WordPress plugin before 1.14.14 does not have authorisation when deleting shipment, allowing any authenticated users, such as subscriber to delete arbitrary shipment

NVD CVE-2023-3365WPScan advisory

medium 6.1 CVE-2023-3671 · published 2023-08-07

Reflected cross-site scripting (XSS) in MultiParcels Shipping For WooCommerce (older than 1.15.4)

Affected
older than 1.15.4
Fixed in
1.15.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MultiParcels Shipping For WooCommerce WordPress plugin before 1.15.4 does not sanitise and escape various parameters before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

NVD CVE-2023-3671WPScan advisory

high 8.8 CVE-2023-2843 · published 2023-08-07

SQL injection in MultiParcels Shipping For WooCommerce (older than 1.14.15)

Affected
older than 1.14.15
Fixed in
1.14.15
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The MultiParcels Shipping For WooCommerce WordPress plugin before 1.14.15 does not properly sanitize and escape a parameter before using it in an SQL statement, which could allow any authenticated users, such as subscribers, to perform SQL Injection attacks.

NVD CVE-2023-2843WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MultiParcels Shipping For WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/multiparcels-shipping-for-woocommerce"><img src="https://laskyr.com/plugins/multiparcels-shipping-for-woocommerce/badge.svg" alt="MultiParcels Shipping For WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit