Plugins · multi-column-tag-map · data as of 2026-11-04
Is Multi-column Tag Map safe? Known vulnerabilities and latest version
- Status
- Closed 2026-01-05
- Known issues on record
- 4
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate multi-column-tag-map && wp plugin delete multi-column-tag-map
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 4 record(s) do not state which versions are affected.
medium 4.4 CVE-2025-14057 · published 2026-01-07
Stored cross-site scripting (XSS) in Multi-column Tag Map (17.0.39 and older)
- Affected
- 17.0.39 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Multi-column Tag Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 17.0.39 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
medium 6.4 CVE-2024-11196 · published 2024-12-21
Stored cross-site scripting (XSS) in Multi-column Tag Map (17.0.33 and older)
- Affected
- 17.0.33 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Multi-column Tag Map plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's mctagmap shortcode in all versions up to, and including, 17.0.33 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-11196Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 6.5 CVE-2023-41651 · published 2024-05-08
Missing authorization check in Multi-column Tag Map (17.0.26 and older)
- Affected
- 17.0.26 and older
- Fixed in
- 17.0.27
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Multi-column Tag Map.This issue affects Multi-column Tag Map: from n/a through 17.0.26.
medium 5.4 CVE-2023-23815 · published 2023-04-06
Stored cross-site scripting (XSS) in Multi-column Tag Map (17.0.24 and older)
- Affected
- 17.0.24 and older
- Fixed in
- 17.0.25
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Alan Jackson Multi-column Tag Map plugin <= 17.0.24 versions.
Recent activity
- 2026-01-05 — closed on wordpress.org (Security Issue).
- 2026-01-07 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14057), fix version not stated.
- 2024-12-21 — Stored cross-site scripting (XSS) disclosed (CVE-2024-11196), fix version not stated.
- 2024-05-08 — Missing authorization check disclosed (CVE-2023-41651), fixed in 17.0.27.
Get an email when Multi-column Tag Map has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Multi-column Tag Map (multi-column-tag-map) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/multi-column-tag-map (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/multi-column-tag-map"><img src="https://laskyr.com/plugins/multi-column-tag-map/badge.svg" alt="Multi-column Tag Map vulnerability status"></a>