Skip to content
Laskyr

Plugins · mountdev-ai-mcp-connector · data as of 2026-11-04

Is MountDev AI MCP Connector for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.6 or newer fixes all of them that state a fix.

Latest version
2.2.0
Last updated
2026-10-01
Active installs
200+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Connect ChatGPT or Claude to WordPress with one address. Edit posts, pages and media, and use any plugin that registers WordPress Abilities. — by Cascadia Web Services

What to do

  1. Update to the latest version (2.2.0). Anything older than 1.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mountdev-ai-mcp-connector --field=version shows what you run; wp plugin update mountdev-ai-mcp-connector updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-85306 · published 2026-09-03

Missing authorization check in MountDev AI MCP Connector for WordPress (1.6.5 and older)

Affected
1.6.5 and older
Fixed in
1.6.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Cascadia Web Services MountDev AI MCP Connector for WordPress allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects MountDev AI MCP Connector for WordPress: from n/a through 1.6.5.

NVD CVE-2026-85306Patchstack advisory

critical 9.8 CVE-2026-15015 · published 2026-07-23

Missing authorization check in MountDev AI MCP Connector for WordPress (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MountDev AI MCP Connector for WordPress plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.6.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to obtain an administrator-bound OAuth Bearer token via a self-registered client, granting full administrator-equivalent access to the plugin's MCP tool surface and all exposed WordPress content, users, and options. This is exploitable by combining the publicly accessible Dynamic Client Registration endpoint, which allows unauthenticated callers to register arbitrary OAuth clients with an attacker-controlled redirect_uri, with the unprotected authorization endpoint to complete the full OAuth flow without any administrator interaction.

NVD CVE-2026-15015Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MountDev AI MCP Connector for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/mountdev-ai-mcp-connector"><img src="https://laskyr.com/plugins/mountdev-ai-mcp-connector/badge.svg" alt="MountDev AI MCP Connector for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit