Skip to content
Laskyr

Plugins · motopress-appointment-lite · data as of 2026-11-04

Is MotoPress Appointment Booking safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.9)

As of 2026-11-04. 3 issues are on record for older versions; version 2.4.8 or newer fixes all of them that state a fix.

Latest version
2.4.9
Last updated
2026-11-03
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

MotoPress Appointment Booking makes it easy for time and service-based businesses to accept bookings and appointments online. — by jetmonsters

What to do

  1. Update to the latest version (2.4.9). Anything older than 2.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get motopress-appointment-lite --field=version shows what you run; wp plugin update motopress-appointment-lite updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-15232 · published 2026-09-02

Missing authorization check in MotoPress Appointment Booking (older than 2.4.8)

Affected
older than 2.4.8
Fixed in
2.4.8
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The MotoPress Appointment Booking WordPress plugin before 2.4.8 does not perform an authorization or ownership check when handling a user-supplied booking identifier on an unauthenticated endpoint, allowing unauthenticated attackers to permanently delete other users' reservations. This is an incomplete fix of CVE-2026-9180: the deletion remains reachable on sites using payment confirmation, confirmed through version 2.4.7.

NVD CVE-2026-15232WPScan advisory

medium 5.3 CVE-2026-9180 · published 2026-07-03

Missing authorization check in MotoPress Appointment Booking (2.4.4 and older)

Affected
2.4.4 and older
Fixed in
2.4.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MotoPress Appointment Booking plugin for WordPress is vulnerable to Authorization Bypass Through User-Controlled Key in all versions up to, and including, 2.4.4. This is due to the `POST /motopress/appointment/v1/bookings` REST endpoint being registered with `'permission_callback' => '__return_true'`, allowing unauthenticated access, while the `createBooking` handler in `BookingsRestController.php` accepts an attacker-supplied `payment_details.booking_id` value and loads the referenced booking via `findById()` without verifying that the caller owns or has any rights to that booking. This makes it possible for unauthenticated attackers to overwrite the customer name, email address, phone number, and `customer_id` of any non-confirmed victim booking by submitting a request with no reservation items, causing `BookingService::createBooking()` to load the existing victim booking object and persist it with attacker-controlled customer data. Victim booking IDs can be harvested prior to exploitation without authentication by querying the also-publicly-accessible `GET /motopress/appointment/v1/bookings/reservations` endpoint with a guessable `service_id` and date range, and only bookings whose status is not `STATUS_CONFIRMED` (e.g., pending or auto-draft) are valid targets.

NVD CVE-2026-9180Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-13454 · published 2026-07-01

SQL injection in MotoPress Appointment Booking (2.4.5 and older)

Affected
2.4.5 and older
Fixed in
2.4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MotoPress Appointment Booking plugin for WordPress is vulnerable to generic SQL Injection via the 's' parameter in all versions up to, and including, 2.4.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with custom-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Exploitation requires the mpa_appointment_employee custom role, meaning any user assigned this role can perform the attack.

NVD CVE-2026-13454Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MotoPress Appointment Booking vulnerability status badge
<a href="https://laskyr.com/plugins/motopress-appointment-lite"><img src="https://laskyr.com/plugins/motopress-appointment-lite/badge.svg" alt="MotoPress Appointment Booking vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit