Skip to content
Laskyr

Plugins · molongui-authorship · data as of 2026-11-04

Is Molongui Authorship safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.3.2)

As of 2026-11-04. 7 issues are on record for older versions; version 5.3.0 or newer fixes all of them that state a fix.

Latest version
5.3.2
Last updated
2026-10-08
Active installs
10,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6.20+

All-in-One Authorship Solution: Seamless Author Box, Guest Authors, and Co-Authors to enhance your site's authority, credibility, engagement, and SEO. — by Molongui

What to do

  1. Update to the latest version (5.3.2). Anything older than 5.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get molongui-authorship --field=version shows what you run; wp plugin update molongui-authorship updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-101920 · published 2026-10-10

DOM-based cross-site scripting (XSS) in Molongui Authorship (5.2.12 and older)

Affected
5.2.12 and older
Fixed in
5.3.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Molongui Authorship – Author Boxes, Guest Authors & Co-Authors for WordPress plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'comment (href attribute inside comment content)' parameter in all versions up to, and including, 5.2.12 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable in the free build because the plugin's author-filter rewriter never appends the ?m_bm=true marker to its own anchors (Plugin::has_pro() returns false), meaning every href the byline script selects and rewrites is fully attacker-controlled.

NVD CVE-2026-101920Wordfence advisoryPlugin source

medium 4.3 CVE-2023-50876 · published 2024-12-09

Missing authorization check in Molongui Authorship (4.7.3 and older)

Affected
4.7.3 and older
Fixed in
4.7.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Molongui Molongui allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Molongui: from n/a through 4.7.3.

NVD CVE-2023-50876Patchstack advisory

low 2.7 CVE-2024-30507 · published 2024-03-29

Missing authorization check in Molongui Authorship (4.7.7 and older)

Affected
4.7.7 and older
Fixed in
4.7.8
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in Molongui.This issue affects Molongui: from n/a through 4.7.7.

NVD CVE-2024-30507Patchstack advisory

medium 6.5 CVE-2024-29764 · published 2024-03-27

Stored cross-site scripting (XSS) in Molongui Authorship (4.7.7 and older)

Affected
4.7.7 and older
Fixed in
4.7.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Molongui allows Stored XSS.This issue affects Molongui: from n/a through 4.7.7.

NVD CVE-2024-29764Patchstack advisory

high 7.5 CVE-2023-7014 · published 2024-02-05

Information disclosure in Molongui Authorship (4.7.4 and older)

Affected
4.7.4 and older
Fixed in
4.7.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Author Box, Guest Author and Co-Authors for Your Posts – Molongui plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.7.4 via the 'ma_debu' parameter. This makes it possible for unauthenticated attackers to extract sensitive data including post author emails and names if applicable.

NVD CVE-2023-7014Wordfence advisoryCode change (fix)

medium 4.8 CVE-2023-39921 · published 2023-11-30

Stored cross-site scripting (XSS) in Molongui Authorship (4.6.19 and older)

Affected
4.6.19 and older
Fixed in
4.6.20
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Molongui Author Box, Guest Author and Co-Authors for Your Posts – Molongui allows Stored XSS.This issue affects Author Box, Guest Author and Co-Authors for Your Posts – Molongui: from n/a through 4.6.19.

NVD CVE-2023-39921Patchstack advisory

medium 6.1 CVE-2023-39164 · published 2023-09-04

Reflected cross-site scripting (XSS) in Molongui Authorship (4.6.19 and older)

Affected
4.6.19 and older
Fixed in
4.6.20
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Molongui Author Box for Authors, Co-Authors, Multiple Authors and Guest Authors – Molongui plugin <= 4.6.19 versions.

NVD CVE-2023-39164Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Molongui Authorship vulnerability status badge
<a href="https://laskyr.com/plugins/molongui-authorship"><img src="https://laskyr.com/plugins/molongui-authorship/badge.svg" alt="Molongui Authorship vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit