Plugins · mollie-payments-for-woocommerce · data as of 2026-11-04
Is Mollie Payments for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 8.2.0
- Last updated
- 2026-10-27
- Active installs
- 100,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Accept all major payment methods in WooCommerce today. Credit cards, iDEAL and more! Fast, safe and intuitive. — by Mollie
What to do
- Update to the latest version (8.2.0). Anything older than 8.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mollie-payments-for-woocommerce --field=version shows what you run; wp plugin update mollie-payments-for-woocommerce updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2025-68501 · published 2026-02-20
Reflected cross-site scripting (XSS) in Mollie Payments for WooCommerce (8.1.1 and older)
- Affected
- 8.1.1 and older
- Fixed in
- 8.1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mollie Mollie Payments for WooCommerce mollie-payments-for-woocommerce allows Reflected XSS.This issue affects Mollie Payments for WooCommerce: from n/a through <= 8.1.1.
medium 6.5 CVE-2025-39362 · published 2025-07-02
Missing authorization check in Mollie Payments for WooCommerce (8.0.2 and older)
- Affected
- 8.0.2 and older
- Fixed in
- 8.0.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Mollie Mollie Payments for WooCommerce mollie-payments-for-woocommerce.This issue affects Mollie Payments for WooCommerce: from n/a through <= 8.0.2.
medium 5.3 CVE-2024-6448 · published 2024-08-28
Information disclosure in Mollie Payments for WooCommerce (7.7.0 and older)
- Affected
- 7.7.0 and older
- Fixed in
- 7.8.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Mollie Payments for WooCommerce plugin for WordPress is vulnerable to information exposure in all versions up to, and including, 7.7.0. This is due to the error reporting being enabled by default in multiple plugin files. This makes it possible for unauthenticated attackers to obtain the full path to instances, which they may be able to use in combination with other vulnerabilities or to simplify reconnaissance work. On its own, this information is of very limited use.
NVD CVE-2024-6448Wordfence advisoryCode change (fix)Plugin source
high 7.2 CVE-2023-6090 · published 2024-02-29
Arbitrary file upload in Mollie Payments for WooCommerce (7.3.11 and older)
- Affected
- 7.3.11 and older
- Fixed in
- 7.3.12
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in Mollie Mollie Payments for WooCommerce.This issue affects Mollie Payments for WooCommerce: from n/a through 7.3.11.
Recent activity
- 2026-10-27 — latest release on wordpress.org (8.2.0).
- 2026-02-20 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-68501), fixed in 8.1.2.
- 2025-07-02 — Missing authorization check disclosed (CVE-2025-39362), fixed in 8.0.3.
- 2024-08-28 — Information disclosure disclosed (CVE-2024-6448), fixed in 7.8.0.
Get an email when Mollie Payments for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mollie Payments for WooCommerce (mollie-payments-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1) · Sensitive data exposure (1) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mollie-payments-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mollie-payments-for-woocommerce"><img src="https://laskyr.com/plugins/mollie-payments-for-woocommerce/badge.svg" alt="Mollie Payments for WooCommerce vulnerability status"></a>