Skip to content
Laskyr

Plugins · mollie-forms · data as of 2026-11-04

Is Mollie Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.11.2)

As of 2026-11-04. 5 issues are on record for older versions; version 2.11.1 or newer fixes all of them that state a fix.

Latest version
2.11.2
Last updated
2026-10-14
Active installs
3,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Create registration forms with payment methods of Mollie. One-time and recurring payments are possible. — by Nick van Wobbie

What to do

  1. Update to the latest version (2.11.2). Anything older than 2.11.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mollie-forms --field=version shows what you run; wp plugin update mollie-forms updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-93773 · published 2026-09-23

SQL injection in Mollie Forms (2.11.0 and older)

Affected
2.11.0 and older
Fixed in
2.11.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor SQL Injection in Mollie Forms <= 2.11.0 versions.

NVD CVE-2026-93773Patchstack advisory

medium 6.5 CVE-2025-47502 · published 2025-05-07

Stored cross-site scripting (XSS) in Mollie Forms (2.7.12 and older)

Affected
2.7.12 and older
Fixed in
2.7.13
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nick van Wobbie Mollie Forms mollie-forms allows Stored XSS.This issue affects Mollie Forms: from n/a through <= 2.7.12.

NVD CVE-2025-47502Patchstack advisory

medium 4.3 CVE-2024-2368 · published 2024-06-05

Cross-site request forgery (CSRF) in Mollie Forms (2.6.13 and older)

Affected
2.6.13 and older
Fixed in
2.6.14 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mollie Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.6.13. This is due to missing or incorrect nonce validation on the duplicateForm() function. This makes it possible for unauthenticated attackers to duplicate forms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2024-2368Wordfence advisoryCode change (fix)

medium 4.3 CVE-2024-1400 · published 2024-03-11

Missing authorization check in Mollie Forms (2.6.3 and older)

Affected
2.6.3 and older
Fixed in
2.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mollie Forms plugin for WordPress is vulnerable to unauthorized post or page duplication due to a missing capability check on the duplicateForm function in all versions up to, and including, 2.6.3. This makes it possible for authenticated attackers, with subscriber access or higher, to duplicate arbitrary posts and pages.

NVD CVE-2024-1400Wordfence advisoryCode change (fix)

medium 4.3 CVE-2024-1645 · published 2024-03-11

Missing authorization check in Mollie Forms (2.6.3 and older)

Affected
2.6.3 and older
Fixed in
2.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mollie Forms plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the exportRegistrations function in all versions up to, and including, 2.6.3. This makes it possible for authenticated attackers, with subscriber access or higher, to export payment data collected by this plugin.

NVD CVE-2024-1645Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Mollie Forms vulnerability status badge
<a href="https://laskyr.com/plugins/mollie-forms"><img src="https://laskyr.com/plugins/mollie-forms/badge.svg" alt="Mollie Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit