Skip to content
Laskyr

Plugins · modular-connector · data as of 2026-11-04

Is Modular DS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.0)

As of 2026-11-04. 3 issues are on record for older versions; version 2.6.0 or newer fixes all of them that state a fix.

Latest version
3.4.0
Last updated
2026-10-13
Active installs
40,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Manage all your WordPress sites from one place. Automate updates, backups, uptime monitoring, security, reports, and more. — by Modular DS

What to do

  1. Update to the latest version (3.4.0). Anything older than 2.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get modular-connector --field=version shows what you run; wp plugin update modular-connector updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-3903 · published 2026-03-11

Cross-site request forgery (CSRF) in Modular DS (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Modular DS: Monitor, update, and backup multiple websites plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.1. This is due to missing nonce validation on the postConfirmOauth() function. This makes it possible for unauthenticated attackers to disconnect the plugin's OAuth/SSO connection via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2026-3903Wordfence advisoryCode change (fix)

critical 10.0 CVE-2026-23800 · published 2026-01-16

Privilege escalation in Modular DS (2.5.2 up to (not including) 2.6.0)

Affected
2.5.2 up to (not including) 2.6.0
Fixed in
2.6.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Modular DS modular-connector allows Privilege Escalation.This issue affects Modular DS: from 2.5.2 before 2.6.0.

NVD CVE-2026-23800Patchstack advisory

critical 9.8 CVE-2026-23550 · published 2026-01-14

Privilege escalation in Modular DS (2.5.1 and older)

Affected
2.5.1 and older
Fixed in
2.5.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in Modular DS Modular DS modular-connector allows Privilege Escalation.This issue affects Modular DS: from n/a through <= 2.5.1.

NVD CVE-2026-23550Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Modular DS vulnerability status badge
<a href="https://laskyr.com/plugins/modular-connector"><img src="https://laskyr.com/plugins/modular-connector/badge.svg" alt="Modular DS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit