Skip to content
Laskyr

Plugins · modal-popup-box · data as of 2026-11-04

Is Modal Popup Box safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.6.2 or newer fixes all of them that state a fix.

Latest version
2.1.3
Last updated
2026-08-20
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Modal Popup Box is a lightweight popup maker builder. Create beautiful popups to display offers, news, videos, forms, and more with smooth animations. — by A WP Life

What to do

  1. Update to the latest version (2.1.3). Anything older than 1.6.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get modal-popup-box --field=version shows what you run; wp plugin update modal-popup-box updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2025-68526 · published 2026-02-20

PHP object injection in Modal Popup Box (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in A WP Life Modal Popup Box modal-popup-box allows Object Injection.This issue affects Modal Popup Box: from n/a through <= 1.6.1.

NVD CVE-2025-68526Patchstack advisory

high 8.8 CVE-2024-2008 · published 2024-04-04

PHP object injection in Modal Popup Box (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Modal Popup Box – Popup Builder, Show Offers And News in Popup plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.5.2 via deserialization of untrusted input in the awl_modal_popup_box_shortcode function. This makes it possible for authenticated attackers, with contributor-level access and above, to inject a PHP Object. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.

NVD CVE-2024-2008Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Modal Popup Box vulnerability status badge
<a href="https://laskyr.com/plugins/modal-popup-box"><img src="https://laskyr.com/plugins/modal-popup-box/badge.svg" alt="Modal Popup Box vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit