Skip to content
Laskyr

Plugins · mobile-login-woocommerce · data as of 2026-11-04

Is OTP Login & Register Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.4)

As of 2026-11-04. 5 issues are on record for older versions; version 2.7.4 or newer fixes all of them that state a fix.

Latest version
2.7.4
Last updated
2026-09-05
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.2.4+

Allow users to log in/sign up with a one-time password (OTP) sent to their mobile device. — by xootix

What to do

  1. Update to the latest version (2.7.4). Anything older than 2.7.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mobile-login-woocommerce --field=version shows what you run; wp plugin update mobile-login-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.4 CVE-2026-110135 · published 2026-10-16

Authentication bypass in OTP Login & Register Woocommerce (older than 2.7.3)

Affected
older than 2.7.3
Fixed in
2.7.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The OTP Login & Register Woocommerce WordPress plugin before 2.7.3 does not adequately limit one-time-password verification attempts, because the attempt limit is tracked against a value the client itself supplies and can change freely, allowing an unauthenticated attacker to bypass the limit and brute-force the short numeric login code to take over an account without its password.

NVD CVE-2026-110135WPScan advisory

medium 4.4 CVE-2026-12402 · published 2026-09-19

Stored cross-site scripting (XSS) in OTP Login & Register Woocommerce (2.7.3 and older)

Affected
2.7.3 and older
Fixed in
2.7.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OTP Login & Register Woocommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'fb-config' Setting in all versions up to, and including, 2.7.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. On multisite installations where administrators do not hold the unfiltered_html capability, this vulnerability can be leveraged to target the network super administrator.

NVD CVE-2026-12402Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2026-12215 · published 2026-09-11

Authentication bypass in OTP Login & Register Woocommerce (2.7.2 and older)

Affected
2.7.2 and older
Fixed in
2.7.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The OTP Login & Register Woocommerce plugin for WordPress is vulnerable to Authentication Bypass via OTP Brute Force in all versions up to, and including, 2.7.2. The vulnerability exists because the OTP rate-limit attempt counter in `process_otp_form` is keyed exclusively on the attacker-controlled `xoo_ml_user_ip_data` cookie's `ip_address` field, allowing unlimited counter resets by simply rotating the cookie, while the OTP itself is generated with PHP's non-cryptographic `rand()` function over a default space of only 9,000 possible values (1000–9999), and both the OTP issuance endpoint (`xoo_ml_login_with_otp`) and verification endpoint (`xoo_ml_otp_form_submit`) are registered as unauthenticated `wp_ajax_nopriv` actions with no nonce or capability checks. This makes it possible for unauthenticated attackers to brute-force the OTP for any registered account and obtain a full WordPress authentication session — including for administrator accounts — via `wp_set_auth_cookie()` in `login_user_with_otp()`. Exploitation requires the attacker to know the target user's registered phone number, which is used to trigger OTP issuance via the unauthenticated `xoo_ml_login_with_otp` endpoint.

NVD CVE-2026-12215Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-5324 · published 2024-06-06

Missing authorization check in OTP Login & Register Woocommerce (2.6.1 and older)

Affected
2.6.1 and older
Fixed in
2.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

Multiple plugins for WordPress utilizing the XootiX Framework are vulnerable to unauthorized modification of data due to a missing capability check on the 'import_settings' function in various versions. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change arbitrary options on affected sites. This can be used to enable new user registration and set the default role for new users to Administrator.

NVD CVE-2024-5324Wordfence advisoryCode change (fix)Plugin source

high 8.1 CVE-2023-2706 · published 2023-05-17

Authentication bypass in OTP Login & Register Woocommerce (2.2 and older)

Affected
2.2 and older
Fixed in
2.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The OTP Login Woocommerce & Gravity Forms plugin for WordPress is vulnerable to authentication bypass. This is due to the fact that when generating OTP codes for users to use in order to login via phone number, the plugin returns these codes in an AJAX response. This makes it possible for unauthenticated attackers to obtain login codes for administrators. This does require an attacker have access to the phone number configured for an account, which can be obtained via social engineering or reconnaissance.

NVD CVE-2023-2706Wordfence advisoryCode change (fix)lana.codesPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
OTP Login & Register Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/mobile-login-woocommerce"><img src="https://laskyr.com/plugins/mobile-login-woocommerce/badge.svg" alt="OTP Login & Register Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit