Skip to content
Laskyr

Plugins · mobile-dj-manager · data as of 2026-11-04

Is MDJM Event Management safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.8.7)

As of 2026-11-04. 7 issues are on record for older versions; version 1.7.8.5 or newer fixes all of them that state a fix.

Latest version
1.7.8.7
Last updated
2026-09-08
Active installs
40+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.0+

MDJM Event Management automates event processes, streamlining from enquiries to completion. Add employees, clients, and create events seamlessly. — by MDJM

What to do

  1. Update to the latest version (1.7.8.7). Anything older than 1.7.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mobile-dj-manager --field=version shows what you run; wp plugin update mobile-dj-manager updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-88802 · published 2026-09-13

Missing authorization check in MDJM Event Management (older than 1.7.8.5)

Affected
older than 1.7.8.5
Fixed in
1.7.8.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The MDJM Event Management WordPress plugin before 1.7.8.5 and the Mobile Events Manager WordPress plugin through 1.4.8.3 do not check a capability, a nonce or the type of the record before permanently deleting the post identified in a request to their playlist entry removal, allowing unauthenticated attackers to destroy arbitrary posts, pages and media attachments, bypassing the trash.

NVD CVE-2026-88802WPScan advisory

high 8.8 CVE-2026-15017 · published 2026-07-23

Privilege escalation in MDJM Event Management (1.7.8.4 and older)

Affected
1.7.8.4 and older
Fixed in
1.7.8.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MDJM Event Management plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.7.8.4. This is due to missing capability checks and nonce verification in the `MDJM_Permissions::set_permissions()` and `MDJM_Employee_Manager::init()` functions, combined with the absence of server-side allow-list validation on the `employee_roles[]` and `new_role` POST parameters before they are passed to `mdjm_set_employee_role()` and `WP_User::set_role()`. This makes it possible for unauthenticated attackers to grant arbitrary MDJM capabilities — including `mdjm_employee` and `mdjm_employee_edit` — to any registered WordPress role, and subsequently leverage a subscriber-level account to escalate privileges to Administrator. `MDJM_Permissions::init()` is registered on the public WordPress `init` hook without any authentication gate, meaning the role-manipulation endpoint is reachable without any prior login.

NVD CVE-2026-15017Wordfence advisoryPlugin source

high 7.2 CVE-2026-7537 · published 2026-06-06

Arbitrary file upload in MDJM Event Management (1.7.8.3 and older)

Affected
1.7.8.3 and older
Fixed in
1.7.8.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MDJM Event Management plugin for WordPress is vulnerable to Arbitrary File Upload in all versions up to, and including, 1.7.8.3 via the mdjm_send_comm_email function. This is due to no file type, extension, or MIME type validation being performed on uploaded files. This makes it possible for authenticated attackers, with administrator-level access and above, to upload files that may be executable, which makes remote code execution possible.

NVD CVE-2026-7537Wordfence advisoryCode change (fix)github.comryankozak.comPlugin source

medium 5.3 CVE-2026-1650 · published 2026-03-07

Missing authorization check in MDJM Event Management (1.7.8.1 and older)

Affected
1.7.8.1 and older
Fixed in
1.7.8.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MDJM Event Management plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the 'custom_fields_controller' function in all versions up to, and including, 1.7.8.1. This makes it possible for unauthenticated attackers to delete arbitrary custom event fields via the 'delete_custom_field' and 'id' parameters.

NVD CVE-2026-1650Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2025-52824 · published 2025-06-27

Missing authorization check in MDJM Event Management (1.7.8.3 and older)

Affected
1.7.8.3 and older
Fixed in
1.7.8.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in MDJM Mobile DJ Manager mobile-dj-manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Mobile DJ Manager: from n/a through <= 1.7.8.3.

NVD CVE-2025-52824Patchstack advisory

high 8.8 CVE-2025-31074 · published 2025-04-01

PHP object injection in MDJM Event Management (1.7.5.2 and older)

Affected
1.7.5.2 and older
Fixed in
1.7.5.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in MDJM Mobile DJ Manager mobile-dj-manager allows Object Injection.This issue affects Mobile DJ Manager: from n/a through <= 1.7.5.2.

NVD CVE-2025-31074Patchstack advisory

high 7.1 CVE-2025-22714 · published 2025-01-24

Reflected cross-site scripting (XSS) in MDJM Event Management (1.7.5.6 and older)

Affected
1.7.5.6 and older
Fixed in
1.7.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in MDJM Mobile DJ Manager mobile-dj-manager allows Reflected XSS.This issue affects Mobile DJ Manager: from n/a through <= 1.7.5.6.

NVD CVE-2025-22714Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MDJM Event Management vulnerability status badge
<a href="https://laskyr.com/plugins/mobile-dj-manager"><img src="https://laskyr.com/plugins/mobile-dj-manager/badge.svg" alt="MDJM Event Management vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit