Plugins · miniorange-oauth-20-server · data as of 2026-11-04
Is WP OAuth Server ( Login with WordPress ) safe? Known vulnerabilities and latest version
- Latest version
- 6.5.0
- Last updated
- 2026-10-08
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
Single Sign-On using WordPress - Login with WordPress to your application/sites using your WordPress account. [24/7 Support] — by miniOrange
What to do
- Update to the latest version (6.5.0). Anything older than 6.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get miniorange-oauth-20-server --field=version shows what you run; wp plugin update miniorange-oauth-20-server updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-107433 · published 2026-10-14
Missing authorization check in WP OAuth Server ( Login with WordPress ) (6.4.0 and older)
- Affected
- 6.4.0 and older
- Fixed in
- 6.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in miniOrange WP OAuth Server miniorange-oauth-20-server allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP OAuth Server: from n/a through 6.4.0.
critical 9.0 CVE-2026-82843 · published 2026-09-23
Authentication bypass in WP OAuth Server ( Login with WordPress ) (older than 6.4.0)
- Affected
- older than 6.4.0
- Fixed in
- 6.4.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WP OAuth Server ( Login with WordPress ) WordPress plugin before 6.4.0 does not bind the OpenID Connect identity assertion it issues to the authorization grant being exchanged, returning instead the assertion belonging to whichever user authenticated most recently, which allows users with the Subscriber role and above to obtain a validly signed identity assertion for another user, including an administrator, and authenticate as them at any application that uses the site for single sign-on.
high 7.5 CVE-2026-19715 · published 2026-08-27
Information disclosure in WP OAuth Server ( Login with WordPress ) (older than 6.3.1)
- Affected
- older than 6.3.1
- Fixed in
- 6.3.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WP OAuth Server ( Login with WordPress ) WordPress plugin before 6.3.1 does not restrict access to the debug log it writes, which is stored at a fixed and publicly reachable location, allowing unauthenticated users to read the OAuth tokens and authorisation codes it has issued as well as user records including password hashes when debug logging is enabled.
critical 9.3 CVE-2026-65520 · published 2026-08-06
SQL injection in WP OAuth Server ( Login with WordPress ) (6.2.0 and older)
- Affected
- 6.2.0 and older
- Fixed in
- 6.2.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated SQL Injection in WP OAuth Server <= 6.2.0 versions.
critical 9.8 CVE-2022-34149 · published 2022-08-22
Authentication bypass in WP OAuth Server ( Login with WordPress ) (3.0.4 and older)
- Affected
- 3.0.4 and older
- Fixed in
- 4.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authentication Bypass vulnerability in miniOrange WP OAuth Server plugin <= 3.0.4 at WordPress.
Recent activity
- 2026-10-08 — latest release on wordpress.org (6.5.0).
- 2026-10-14 — Missing authorization check disclosed (CVE-2026-107433), fixed in 6.5.0.
- 2026-09-23 — Authentication bypass disclosed (CVE-2026-82843), fixed in 6.4.0.
- 2026-08-27 — Information disclosure disclosed (CVE-2026-19715), fixed in 6.3.1.
Get an email when WP OAuth Server ( Login with WordPress ) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP OAuth Server ( Login with WordPress ) (miniorange-oauth-20-server) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by miniOrange (14 tracked)
Types found in this plugin: Authentication bypass (2) · Missing authorization (1) · Sensitive data exposure (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/miniorange-oauth-20-server (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/miniorange-oauth-20-server"><img src="https://laskyr.com/plugins/miniorange-oauth-20-server/badge.svg" alt="WP OAuth Server ( Login with WordPress ) vulnerability status"></a>