Plugins · miniorange-discord-integration · data as of 2026-11-04
Is miniOrange Discord Integration safe? Known vulnerabilities and latest version
- Latest version
- 2.2.6
- Last updated
- 2026-08-25
- Active installs
- 100+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Integrate Discord with WordPress using OAuth. Enable Discord Login, role mapping, avatar sync, profile mapping, and SSO. — by miniOrange
What to do
- Update to the latest version (2.2.6). Anything older than 2.2.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get miniorange-discord-integration --field=version shows what you run; wp plugin update miniorange-discord-integration updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.1 CVE-2026-59545 · published 2026-07-23
Authentication bypass in miniOrange Discord Integration (2.2.4 and older)
- Affected
- 2.2.4 and older
- Fixed in
- 2.2.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Authentication in miniOrange Discord Integration <= 2.2.4 versions.
high 8.1 CVE-2025-47672 · published 2025-05-23
File inclusion in miniOrange Discord Integration (2.2.2 and older)
- Affected
- 2.2.2 and older
- Fixed in
- 2.2.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in miniOrange miniOrange Discord Integration miniorange-discord-integration allows PHP Local File Inclusion.This issue affects miniOrange Discord Integration: from n/a through <= 2.2.2.
medium 6.5 CVE-2022-3082 · published 2022-10-17
Cross-site request forgery (CSRF) in miniOrange Discord Integration (older than 2.1.6)
- Affected
- older than 2.1.6
- Fixed in
- 2.1.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The miniOrange Discord Integration WordPress plugin before 2.1.6 does not have authorisation and CSRF in some of its AJAX actions, allowing any logged in users, such as subscriber to call them, and disable the app for example
Recent activity
- 2026-08-25 — latest release on wordpress.org (2.2.6).
- 2026-07-23 — Authentication bypass disclosed (CVE-2026-59545), fixed in 2.2.5.
- 2025-05-23 — File inclusion disclosed (CVE-2025-47672), fixed in 2.2.3.
- 2022-10-17 — Cross-site request forgery (CSRF) disclosed (CVE-2022-3082), fixed in 2.1.6.
Get an email when miniOrange Discord Integration has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for miniOrange Discord Integration (miniorange-discord-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by miniOrange (14 tracked)
Types found in this plugin: Authentication bypass (1) · File inclusion (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/miniorange-discord-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/miniorange-discord-integration"><img src="https://laskyr.com/plugins/miniorange-discord-integration/badge.svg" alt="miniOrange Discord Integration vulnerability status"></a>