Plugins · minify-html-markup · data as of 2026-11-04
Is Minify HTML safe? Known vulnerabilities and latest version
- Latest version
- 2.1.13
- Last updated
- 2026-03-18
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.2.4+
Minify HTML output for clean looking markup and faster downloading. — by Tim Eckel
What to do
- Update to the latest version (2.1.13). Anything older than 2.1.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get minify-html-markup --field=version shows what you run; wp plugin update minify-html-markup updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-3191 · published 2026-03-31
Cross-site request forgery (CSRF) in Minify HTML (2.1.12 and older)
- Affected
- 2.1.12 and older
- Fixed in
- 2.1.13 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Minify HTML plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.12. This is due to missing or incorrect nonce validation on the 'minify_html_menu_options' function. This makes it possible for unauthenticated attackers to update plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2026-3191Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2024-12579 · published 2024-12-13
Denial of service in Minify HTML (2.1.10 and older)
- Affected
- 2.1.10 and older
- Fixed in
- 2.1.11 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Minify HTML plugin for WordPress is vulnerable to Regular Expression Denial of Service (ReDoS) in all versions up to, and including, 2.1.10. This is due to processing user-supplied input as a regular expression. This makes it possible for unauthenticated attackers to create comments that can cause catastrophic backtracking and break pages.
high 8.8 CVE-2023-26014 · published 2023-05-23
Cross-site request forgery (CSRF) in Minify HTML (2.1.7 and older)
- Affected
- 2.1.7 and older
- Fixed in
- 2.1.8
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Tim Eckel Minify HTML plugin <= 2.1.7 vulnerability.
Recent activity
- 2026-03-18 — latest release on wordpress.org (2.1.13).
- 2026-03-31 — Cross-site request forgery (CSRF) disclosed (CVE-2026-3191), fixed in 2.1.13.
- 2024-12-13 — Denial of service disclosed (CVE-2024-12579), fixed in 2.1.11.
- 2023-05-23 — Cross-site request forgery (CSRF) disclosed (CVE-2023-26014), fixed in 2.1.8.
Get an email when Minify HTML has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Minify HTML (minify-html-markup) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Denial of service (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/minify-html-markup (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/minify-html-markup"><img src="https://laskyr.com/plugins/minify-html-markup/badge.svg" alt="Minify HTML vulnerability status"></a>