Skip to content
Laskyr

Plugins · min-and-max-quantity-for-woocommerce · data as of 2026-11-04

Is Minimum and Maximum Quantity for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.4)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.3 or newer fixes all of them that state a fix.

Latest version
2.1.4
Last updated
2026-10-26
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Allow you to set a minimum or maximum purchase quantity for the WooCommerce store. — by Dotstore

What to do

  1. Update to the latest version (2.1.4). Anything older than 2.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get min-and-max-quantity-for-woocommerce --field=version shows what you run; wp plugin update min-and-max-quantity-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-93651 · published 2026-09-30

PHP object injection in Minimum and Maximum Quantity for WooCommerce (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
2.1.3
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Author PHP Object Injection in Minimum and Maximum Quantity for WooCommerce <= 2.1.2 versions.

NVD CVE-2026-93651Patchstack advisory

medium 4.3 CVE-2024-54227 · published 2024-12-09

Missing authorization check in Minimum and Maximum Quantity for WooCommerce (2.0.0 and older)

Affected
2.0.0 and older
Fixed in
2.1.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Dotstore Minimum and Maximum Quantity for WooCommerce min-and-max-quantity-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Minimum and Maximum Quantity for WooCommerce: from n/a through <= 2.0.0.

NVD CVE-2024-54227Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Minimum and Maximum Quantity for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/min-and-max-quantity-for-woocommerce"><img src="https://laskyr.com/plugins/min-and-max-quantity-for-woocommerce/badge.svg" alt="Minimum and Maximum Quantity for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit