Skip to content
Laskyr

Plugins · meta-box-gallerymeta · data as of 2026-11-04

Is Meta-box GalleryMeta safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1)

As of 2026-11-04. 2 issues are on record for older versions; version 3.1 or newer fixes all of them that state a fix.

Latest version
3.1
Last updated
2026-01-26
Active installs
fewer than 10
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Just another gallery plugin. Simple but flexible. — by Md. Shahinur Islam

What to do

  1. Update to the latest version (3.1). Anything older than 3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get meta-box-gallerymeta --field=version shows what you run; wp plugin update meta-box-gallerymeta updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-1302 · published 2026-01-24

Stored cross-site scripting (XSS) in Meta-box GalleryMeta (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Meta-box GalleryMeta plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 3.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-1302Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-0687 · published 2026-01-24

Missing authorization check in Meta-box GalleryMeta (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Meta-box GalleryMeta plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'mb_gallery' custom post type in all versions up to, and including, 3.0.1. This makes it possible for authenticated attackers, with Author-level access and above, to create and publish galleries.

NVD CVE-2026-0687Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Meta-box GalleryMeta vulnerability status badge
<a href="https://laskyr.com/plugins/meta-box-gallerymeta"><img src="https://laskyr.com/plugins/meta-box-gallerymeta/badge.svg" alt="Meta-box GalleryMeta vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit