Skip to content
Laskyr

Plugins · meta-box · data as of 2026-11-01

Is Meta Box safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.15.3)

As of 2026-11-01. 8 issues are on record for older versions; version 5.15.3 or newer fixes all of them that state a fix.

Latest version
5.15.3
Last updated
2026-10-20
Active installs
500,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Meta Box plugin is a powerful, professional developer toolkit to create custom meta boxes and custom fields for your custom post types in WordPress. — by Meta Box

What to do

  1. Update to the latest version (5.15.3). Anything older than 5.15.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get meta-box --field=version shows what you run; wp plugin update meta-box updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-109216 · published 2026-10-29

Stored cross-site scripting (XSS) in Meta Box (5.15.2 and older)

Affected
5.15.2 and older
Fixed in
5.15.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Meta Box – A Framework for Dynamic Websites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'profile_background[<attacker-chosen key>]' parameter in all versions up to, and including, 5.15.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitability depends on a consuming plugin or theme built on Meta Box that exposes the background field to lower-privileged users and renders stored values via the rwmb_the_value()/format_single_value() pattern; the effective minimum privilege is whatever role that consumer permits, demonstrated at Subscriber level.

NVD CVE-2026-109216Wordfence advisorygithub.comPlugin source

medium 6.5 CVE-2026-109700 · published 2026-10-20

Missing authorization check in Meta Box (5.15.2 and older)

Affected
5.15.2 and older
Fixed in
5.15.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in eLightUp Meta Box – WordPress Custom Fields Framework meta-box allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Meta Box – WordPress Custom Fields Framework: from n/a through 5.15.2.

NVD CVE-2026-109700Patchstack advisory

medium 5.5 CVE-2026-15248 · published 2026-08-02

Missing authorization check in Meta Box (older than 5.13.1)

Affected
older than 5.13.1
Fixed in
5.13.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Meta Box WordPress plugin before 5.13.1 does not verify that a user is authorized to delete the supplied attachment before deleting it, allowing users with a low-privilege role such as Contributor to permanently delete arbitrary media attachments belonging to other users.

NVD CVE-2026-15248WPScan advisory

medium 6.8 CVE-2026-39468 · published 2026-06-15

Arbitrary file deletion in Meta Box (5.11.1 and older)

Affected
5.11.1 and older
Fixed in
5.11.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Arbitrary File Deletion in Meta Box – WordPress Custom Fields Framework <= 5.11.1 versions.

NVD CVE-2026-39468Patchstack advisory

high 7.2 CVE-2025-14675 · published 2026-03-07

Arbitrary file deletion in Meta Box (5.11.1 and older)

Affected
5.11.1 and older
Fixed in
5.11.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Meta Box plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'ajax_delete_file' function in all versions up to, and including, 5.11.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php).

NVD CVE-2025-14675Wordfence advisoryCode change (fix)github.comPlugin source

high 7.1 CVE-2024-43235 · published 2024-11-01

Missing authorization check in Meta Box (5.9.10 and older)

Affected
5.9.10 and older
Fixed in
5.9.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in MetaBox.Io Meta Box – WordPress Custom Fields Framework allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Meta Box – WordPress Custom Fields Framework: from n/a through 5.9.10.

NVD CVE-2024-43235Patchstack advisory

medium 4.3 CVE-2024-1204 · published 2024-04-15

Security issue in Meta Box (older than 5.9.4)

Affected
older than 5.9.4
Fixed in
5.9.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Meta Box WordPress plugin before 5.9.4 does not prevent users with at least the contributor role from access arbitrary custom fields assigned to other user's posts.

NVD CVE-2024-1204WPScan advisory

medium 5.4 CVE-2023-6526 · published 2024-02-05

Stored cross-site scripting (XSS) in Meta Box (5.9.2 and older)

Affected
5.9.2 and older
Fixed in
5.9.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Meta Box – WordPress Custom Fields Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom post meta values displayed through the plugin's shortcode in all versions up to, and including, 5.9.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-6526Wordfence advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Meta Box vulnerability status badge
<a href="https://laskyr.com/plugins/meta-box"><img src="https://laskyr.com/plugins/meta-box/badge.svg" alt="Meta Box vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit