Plugins · mesmerize-companion · data as of 2026-11-04
Is Mesmerize Companion safe? Known vulnerabilities and latest version
- Latest version
- 1.6.175
- Last updated
- 2026-08-12
- Active installs
- 50,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
The Mesmerize Companion plugin adds drag and drop page builder functionality to the Mesmerize theme. — by Horea Radu
What to do
- Update to the latest version (1.6.175). Anything older than 1.6.135 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mesmerize-companion --field=version shows what you run; wp plugin update mesmerize-companion updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-12027 · published 2026-02-19
Missing authorization check in Mesmerize Companion (1.6.158 and older)
- Affected
- 1.6.158 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Mesmerize Companion plugin for WordPress is vulnerable to unauthorized access and modification of data due to a missing capability check on the "openPageInCustomizer" and "openPageInDefaultEditor" functions in all versions up to, and including, 1.6.158. This makes it possible for authenticated attackers - with subscriber level access and above, on websites with the Mesmerize theme activated - to mark arbitrary pages as maintainable, wrap their content in custom sections, change page template metadata, and toggle the default editor flag without proper authorization.
medium 6.4 CVE-2024-3494 · published 2024-05-08
Stored cross-site scripting (XSS) in Mesmerize Companion (1.6.148 and older)
- Affected
- 1.6.148 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Mesmerize Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'mesmerize_contact_form' shortcode in all versions up to, and including, 1.6.148 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2022-4481 · published 2023-01-16
Stored cross-site scripting (XSS) in Mesmerize Companion (older than 1.6.135)
- Affected
- older than 1.6.135
- Fixed in
- 1.6.135
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Mesmerize Companion WordPress plugin before 1.6.135 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Recent activity
- 2026-08-12 — latest release on wordpress.org (1.6.175).
- 2026-02-19 — Missing authorization check disclosed (CVE-2025-12027), fix version not stated.
- 2024-05-08 — Stored cross-site scripting (XSS) disclosed (CVE-2024-3494), fix version not stated.
- 2023-01-16 — Stored cross-site scripting (XSS) disclosed (CVE-2022-4481), fixed in 1.6.135.
Get an email when Mesmerize Companion has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mesmerize Companion (mesmerize-companion) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Horea Radu (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mesmerize-companion (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mesmerize-companion"><img src="https://laskyr.com/plugins/mesmerize-companion/badge.svg" alt="Mesmerize Companion vulnerability status"></a>