Plugins · menu-in-post · data as of 2026-11-04
Is Menu In Post safe? Known vulnerabilities and latest version
- Latest version
- 1.5.0
- Last updated
- 2026-08-20
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A simple but flexible plugin to allow the use of menus in posts and pages. — by linux4me2
What to do
- Update to the latest version (1.5.0). Anything older than 1.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get menu-in-post --field=version shows what you run; wp plugin update menu-in-post updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-22349 · published 2026-01-22
Cross-site scripting (XSS) in Menu In Post (1.4.1 and older)
- Affected
- 1.4.1 and older
- Fixed in
- 1.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in linux4me2 Menu In Post menu-in-post allows DOM-Based XSS.This issue affects Menu In Post: from n/a through <= 1.4.1.
Recent activity
- 2026-08-20 — latest release on wordpress.org (1.5.0).
- 2026-01-22 — Cross-site scripting (XSS) disclosed (CVE-2026-22349), fixed in 1.5.0.
Get an email when Menu In Post has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Menu In Post (menu-in-post) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/menu-in-post (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/menu-in-post"><img src="https://laskyr.com/plugins/menu-in-post/badge.svg" alt="Menu In Post vulnerability status"></a>