Skip to content
Laskyr

Plugins · menu-icons · data as of 2026-11-04

Is Menu Icons by Themeisle safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.13.26)

As of 2026-11-04. 2 issues are on record for older versions; version 0.13.21 or newer fixes all of them that state a fix.

Latest version
0.13.26
Last updated
2026-11-02
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Add icons to WordPress navigation menus easily — pick from Font Awesome, Dashicons, image icons & more. Style menu items with custom colors & sizes. — by Themeisle

What to do

  1. Update to the latest version (0.13.26). Anything older than 0.13.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get menu-icons --field=version shows what you run; wp plugin update menu-icons updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1755 · published 2026-02-03

Stored cross-site scripting (XSS) in Menu Icons by Themeisle (0.13.20 and older)

Affected
0.13.20 and older
Fixed in
0.13.21 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Menu Icons by ThemeIsle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘_wp_attachment_image_alt’ post meta in all versions up to, and including, 0.13.20 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1755Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2024-4635 · published 2024-05-16

Stored cross-site scripting (XSS) in Menu Icons by Themeisle (0.13.13 and older)

Affected
0.13.13 and older
Fixed in
0.13.14 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Menu Icons by ThemeIsle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘add_mime_type’ function in versions up to, and including, 0.13.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4635Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Menu Icons by Themeisle vulnerability status badge
<a href="https://laskyr.com/plugins/menu-icons"><img src="https://laskyr.com/plugins/menu-icons/badge.svg" alt="Menu Icons by Themeisle vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit