Skip to content
Laskyr

Plugins · memsource-connector · data as of 2026-11-04

Is Phrase TMS Integration for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.2)

As of 2026-11-04. 1 issue is on record for older versions; version 4.7.6 or newer fixes all of them that state a fix.

Latest version
4.9.2
Last updated
2026-11-02
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

We’re transforming language technology, opening the door to global business so you can reach more people, make deeper connections, and drive growth. — by Phrase

What to do

  1. Update to the latest version (4.9.2). Anything older than 4.7.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get memsource-connector --field=version shows what you run; wp plugin update memsource-connector updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-12168 · published 2026-01-17

Missing authorization check in Phrase TMS Integration for WordPress (4.7.5 and older)

Affected
4.7.5 and older
Fixed in
4.7.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Phrase TMS Integration for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'wp_ajax_delete_log' AJAX endpoint in all versions up to, and including, 4.7.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete log files.

NVD CVE-2025-12168Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Phrase TMS Integration for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/memsource-connector"><img src="https://laskyr.com/plugins/memsource-connector/badge.svg" alt="Phrase TMS Integration for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit