Skip to content
Laskyr

Plugins · mementor-core · data as of 2026-11-04

Is Mementor Core safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.2)

As of 2026-11-04. 1 issue is on record for older versions; version 2.2.6 or newer fixes all of them that state a fix.

Latest version
3.0.2
Last updated
2026-07-06
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Enhance WordPress with Mementor branding, custom dashboard, and optimized admin experience for Norwegian businesses. — by Norse Digital Group LLC

What to do

  1. Update to the latest version (3.0.2). Anything older than 2.2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mementor-core --field=version shows what you run; wp plugin update mementor-core updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2025-11168 · published 2025-11-11

Privilege escalation in Mementor Core (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
2.2.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Mementor Core plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.2.5. This is due to plugin not properly handling the user switch back function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges by accessing an administrator account through the switch back functionality.

NVD CVE-2025-11168Wordfence advisorywordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Mementor Core vulnerability status badge
<a href="https://laskyr.com/plugins/mementor-core"><img src="https://laskyr.com/plugins/mementor-core/badge.svg" alt="Mementor Core vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit