Plugins · members · data as of 2026-11-01
Is Members safe? Known vulnerabilities and latest version
- Latest version
- 3.3.1
- Last updated
- 2026-10-30
- Active installs
- 300,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
The best WordPress membership and user role editor plugin. Edit roles, restrict content, and now manage it all with an AI assistant. — by Blair Williams
What to do
- Update to the latest version (3.3.1). Anything older than 3.2.23 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get members --field=version shows what you run; wp plugin update members updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-12426 · published 2026-07-11
Information disclosure in Members (3.2.22 and older)
- Affected
- 3.2.22 and older
- Fixed in
- 3.2.23 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Members – Membership & User Role Editor Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.2.22 via the members_filter_protected_posts_for_rest. This makes it possible for unauthenticated attackers to extract determine the existence and exact count of access-restricted posts, and use per-page pagination as a boolean oracle to infer keywords and content contained within those hidden restricted posts.
NVD CVE-2026-12426Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2024-11008 · published 2024-12-11
Information disclosure in Members (3.2.10 and older)
- Affected
- 3.2.10 and older
- Fixed in
- 3.2.11 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Members – Membership & User Role Editor Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.2.10 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as administrator.
Recent activity
- 2026-10-30 — latest release on wordpress.org (3.3.1).
- 2026-07-11 — Information disclosure disclosed (CVE-2026-12426), fixed in 3.2.23.
- 2024-12-11 — Information disclosure disclosed (CVE-2024-11008), fixed in 3.2.11.
Get an email when Members has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Members (members) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/members (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/members"><img src="https://laskyr.com/plugins/members/badge.svg" alt="Members vulnerability status"></a>