Plugins · memberful-wp · data as of 2026-11-04
Is Memberful safe? Known vulnerabilities and latest version
- Latest version
- 1.82.3
- Last updated
- 2026-10-26
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Sell memberships and restrict access to content with WordPress and Memberful. — by memberful
What to do
- Update to the latest version (1.82.3). Anything older than 1.82.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get memberful-wp --field=version shows what you run; wp plugin update memberful-wp updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-104401 · published 2026-10-05
Information disclosure in Memberful (1.81.2 and older)
- Affected
- 1.81.2 and older
- Fixed in
- 1.82.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in Memberful Memberful - Membership Plugin memberful-wp allows Retrieve Embedded Sensitive Data.This issue affects Memberful - Membership Plugin: from n/a through 1.81.2.
high 8.0 CVE-2026-103067 · published 2026-10-01
Cross-site request forgery (CSRF) in Memberful (1.81.0 and older)
- Affected
- 1.81.0 and older
- Fixed in
- 1.81.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Memberful Memberful - Membership Plugin memberful-wp allows Cross Site Request Forgery.This issue affects Memberful - Membership Plugin: from n/a through 1.81.0.
medium 5.3 CVE-2025-58000 · published 2025-09-22
Missing authorization check in Memberful (1.75.0 and older)
- Affected
- 1.75.0 and older
- Fixed in
- 1.76.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in memberful Memberful - Membership Plugin memberful-wp allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Memberful - Membership Plugin: from n/a through <= 1.75.0.
medium 5.3 CVE-2024-11294 · published 2024-12-17
Information disclosure in Memberful (1.73.9 and older)
- Affected
- 1.73.9 and older
- Fixed in
- 1.74.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Memberful plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.73.9 via the WordPress core search feature. This makes it possible for unauthenticated attackers to extract sensitive data from posts that have been restricted to higher-level roles such as site members.
medium 5.4 CVE-2024-9242 · published 2024-10-04
Stored cross-site scripting (XSS) in Memberful (1.73.7 and older)
- Affected
- 1.73.7 and older
- Fixed in
- 1.74.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Memberful – Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'memberful_buy_subscription_link' and 'memberful_podcasts_link' shortcodes in all versions up to, and including, 1.73.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-9242Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-26 — latest release on wordpress.org (1.82.3).
- 2026-10-05 — Information disclosure disclosed (CVE-2026-104401), fixed in 1.82.0.
- 2026-10-01 — Cross-site request forgery (CSRF) disclosed (CVE-2026-103067), fixed in 1.81.1.
- 2025-09-22 — Missing authorization check disclosed (CVE-2025-58000), fixed in 1.76.0.
Get an email when Memberful has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Memberful (memberful-wp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (2) · Cross-site request forgery (CSRF) (1) · Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/memberful-wp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/memberful-wp"><img src="https://laskyr.com/plugins/memberful-wp/badge.svg" alt="Memberful vulnerability status"></a>