Plugins · memberfindme · data as of 2026-11-04
Is MembershipWorks safe? Known vulnerabilities and latest version
- Latest version
- 6.17
- Last updated
- 2026-10-27
- Active installs
- 2,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
All-in-one membership, directory, events and donations for organizations. Secure member profiles, renewals, upgrades and limit member only access to c … — by MembershipWorks
What to do
- Update to the latest version (6.17). Anything older than 6.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get memberfindme --field=version shows what you run; wp plugin update memberfindme updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2025-12018 · published 2025-11-12
Stored cross-site scripting (XSS) in MembershipWorks (6.14 and older)
- Affected
- 6.14 and older
- Fixed in
- 6.15 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The MembershipWorks – Membership, Events & Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 6.14 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
NVD CVE-2025-12018Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source
Recent activity
- 2026-10-27 — latest release on wordpress.org (6.17).
- 2025-11-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12018), fixed in 6.15.
Get an email when MembershipWorks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for MembershipWorks (memberfindme) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/memberfindme (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/memberfindme"><img src="https://laskyr.com/plugins/memberfindme/badge.svg" alt="MembershipWorks vulnerability status"></a>