Skip to content
Laskyr

Plugins · melapress-role-editor · data as of 2026-11-04

Is Melapress Role Editor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.2.0 or newer fixes all of them that state a fix.

Latest version
1.4.0
Last updated
2026-10-30
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

The complete WordPress user roles plugin for everyone — by Melapress

What to do

  1. Update to the latest version (1.4.0). Anything older than 1.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get melapress-role-editor --field=version shows what you run; wp plugin update melapress-role-editor updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2025-14866 · published 2026-01-23

Privilege escalation in Melapress Role Editor (1.1.1 and older)

Affected
1.1.1 and older
Fixed in
1.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Melapress Role Editor plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.1.1. This is due to a misconfigured capability check on the 'save_secondary_roles_field' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to assign themselves additional roles including Administrator.

NVD CVE-2025-14866Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Melapress Role Editor vulnerability status badge
<a href="https://laskyr.com/plugins/melapress-role-editor"><img src="https://laskyr.com/plugins/melapress-role-editor/badge.svg" alt="Melapress Role Editor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit