Skip to content
Laskyr

Plugins · megamenu · data as of 2026-11-01

Is Max Mega Menu safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.10.8)

As of 2026-11-01. 2 issues are on record for older versions; version 3.3.1 or newer fixes all of them that state a fix.

Latest version
3.10.8
Last updated
2026-09-14
Active installs
300,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

An easy to use mega menu plugin. Written the WordPress way. — by megamenu

What to do

  1. Update to the latest version (3.10.8). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get megamenu --field=version shows what you run; wp plugin update megamenu updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2024-28003 · published 2024-03-28

Missing authorization check in Max Mega Menu (3.3 and older)

Affected
3.3 and older
Fixed in
3.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Megamenu Max Mega Menu.This issue affects Max Mega Menu: from n/a through 3.3.

NVD CVE-2024-28003Patchstack advisory

medium 6.1 CVE-2017-18525 · published 2019-08-21

Cross-site scripting (XSS) in Max Mega Menu (older than 2.4)

Affected
older than 2.4
Fixed in
2.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The megamenu plugin before 2.4 for WordPress has XSS.

NVD CVE-2017-18525wordpress.org

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Max Mega Menu vulnerability status badge
<a href="https://laskyr.com/plugins/megamenu"><img src="https://laskyr.com/plugins/megamenu/badge.svg" alt="Max Mega Menu vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit