Plugins · mediavine-control-panel · data as of 2026-11-04
Is Mediavine Control Panel safe? Known vulnerabilities and latest version
- Latest version
- 2.10.12
- Last updated
- 2026-08-25
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.3+
Manage your ads, analytics and more with our lightweight plugin! — by mediavine
What to do
- Update to the latest version (2.10.12). Anything older than 2.10.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get mediavine-control-panel --field=version shows what you run; wp plugin update mediavine-control-panel updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-25424 · published 2026-07-23
Missing authorization check in Mediavine Control Panel (2.10.10 and older)
- Affected
- 2.10.10 and older
- Fixed in
- 2.10.11 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Broken Access Control in Mediavine Control Panel <= 2.10.10 versions.
medium 5.3 CVE-2025-39556 · published 2025-04-16
Information disclosure in Mediavine Control Panel (2.10.6 and older)
- Affected
- 2.10.6 and older
- Fixed in
- 2.10.7
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in mediavine Mediavine Control Panel mediavine-control-panel allows Retrieve Embedded Sensitive Data.This issue affects Mediavine Control Panel: from n/a through <= 2.10.6.
medium 6.5 CVE-2024-43218 · published 2024-08-12
Cross-site scripting (XSS) in Mediavine Control Panel (2.10.4 and older)
- Affected
- 2.10.4 and older
- Fixed in
- 2.10.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in mediavine Mediavine Control Panel mediavine-control-panel.This issue affects Mediavine Control Panel: from n/a through <= 2.10.4.
high 8.8 CVE-2023-44259 · published 2023-10-10
Cross-site request forgery (CSRF) in Mediavine Control Panel (2.10.2 and older)
- Affected
- 2.10.2 and older
- Fixed in
- 2.10.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Mediavine Mediavine Control Panel plugin <= 2.10.2 versions.
Recent activity
- 2026-08-25 — latest release on wordpress.org (2.10.12).
- 2026-07-23 — Missing authorization check disclosed (CVE-2026-25424), fixed in 2.10.11.
- 2025-04-16 — Information disclosure disclosed (CVE-2025-39556), fixed in 2.10.7.
- 2024-08-12 — Cross-site scripting (XSS) disclosed (CVE-2024-43218), fixed in 2.10.5.
Get an email when Mediavine Control Panel has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Mediavine Control Panel (mediavine-control-panel) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Sensitive data exposure (1) · Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/mediavine-control-panel (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/mediavine-control-panel"><img src="https://laskyr.com/plugins/mediavine-control-panel/badge.svg" alt="Mediavine Control Panel vulnerability status"></a>