Skip to content
Laskyr

Plugins · mediapress · data as of 2026-11-04

Is MediaPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.3)

As of 2026-11-04. 3 issues are on record for older versions; version 1.6.3 or newer fixes all of them that state a fix.

Latest version
1.6.3
Last updated
2025-12-31
Active installs
3,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.0

MediaPress is the most advanced and feature rich media gallery plugin for BuddyPress & WordPress. — by BuddyDev

What to do

  1. Update to the latest version (1.6.3). Anything older than 1.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get mediapress --field=version shows what you run; wp plugin update mediapress updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-22519 · published 2026-01-08

Stored cross-site scripting (XSS) in MediaPress (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in BuddyDev MediaPress mediapress allows Stored XSS.This issue affects MediaPress: from n/a through <= 1.6.2.

NVD CVE-2026-22519Patchstack advisory

medium 6.4 CVE-2025-14552 · published 2026-01-06

Stored cross-site scripting (XSS) in MediaPress (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The MediaPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's mpp-uploader shortcode in all versions up to, and including, 1.6.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14552Wordfence advisoryPlugin source

high 7.5 CVE-2025-58608 · published 2025-09-03

File inclusion in MediaPress (1.5.9.1 and older)

Affected
1.5.9.1 and older
Fixed in
1.6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in BuddyDev MediaPress mediapress allows PHP Local File Inclusion.This issue affects MediaPress: from n/a through <= 1.5.9.1.

NVD CVE-2025-58608Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MediaPress vulnerability status badge
<a href="https://laskyr.com/plugins/mediapress"><img src="https://laskyr.com/plugins/mediapress/badge.svg" alt="MediaPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit